Operations Manager 2007 用 Microsoft System Management Server 2003 管理パック

Operations Manager 2007 用 Microsoft® System Management Server 2003 管理パックへようこそ。この管理パックは、SMS 2003 の監視のための新機能と改善された機能を提供します。

管理パックのリソース

機能およびリソースの詳細については、以下のトピックを参照してください。

Systems Management Server 2003 管理パックの概要

  • 管理パックの監視シナリオ

  • SMS 2003 管理パックの展開

  • SMS 2003 管理パックの操作タスクの実行

  • SMS 2003 管理パックのトラブルシューティング

  • Microsoft System Management Server 2003 管理パックの参照資料


Systems Management Server 2003 管理パックの概要

このガイドでは、SMS 2003 管理パックに関する展開と技術についての情報を詳しく説明していきます。この情報により、管理パックの展開を計画し、管理パックが提供する機能について理解できます。また、IT 組織でそれらの機能を使用し、メリットをもたらす方法を確認できます。

SMS 用の System Center Operations Manager 2007 管理パックは、SMS 2003 の監視のための次のような改善された機能を提供します

  • すべての SMS 2003 サービスの開始と停止の監視。これには、Windows Management Instrumentation (WMI)、インターネット インフォメーション サービス (IIS)、バックグラウンド インテリジェント転送サービス (BITS) および Microsoft SQL Server™ などの重要な依存サービスも含まれます。

  • SMS 管理者に重大な SMS ステータス メッセージの警告。

  • プライマリ サイト サーバーと管理ポイントの両方で、データ探索レコード (DDR)、ソフトウェア インベントリ、ハードウェア インベントリ、ステータス メッセージ、およびソフトウェア メータリングのバックログを監視。

  • システム リソースの使用状況の監視。

  • 処理率の監視。

  • ビューとレポートを使用して、多くの SMS パフォーマンス カウンタのパフォーマンス傾向の監視。

  • すべてのアラートと処理ルールに関する製品ナレッジ コンテンツ。

  • すべての SMS 2003 コンピュータとコンピュータ グループの検出。

  • ビュー。

  • SMS 2003 の管理ポイントおよびサーバー グループのパフォーマンス、可用性、および構成を表示するレポート。これには、パフォーマンス、構成、および可用性の傾向に関する Systems Center Operations Manager 2007 の強化されたレポート機能を提供するリンク レポートも含まれます。

  • Device Management Feature Pack の監視。

  • SMS 管理コンソール アプリケーションを実行するためのタスク。

  • すべての SMS サーバーの役割と SMS アドバンスト クライアントの稼働状態を含む状態の表示。

  • 重要な SMS サーバーと SMS クライアント情報のサービスの検出。

  • SMS サイト バックアップの実行により発生する [サービスは利用できません] アラートの抑制。

  • SMS サイト階層のトポロジ図 (SMS 2003 Service Pack 3 が必要です)。

  • SMS プログラム プロパティを使用した、分散プログラムの実行エラーに関する、SMS 2003 Service Pack 3 (SP3) の構成可能なアラート。

監視のシナリオと機能の詳細については、「管理パックの監視シナリオ」を参照してください。SMS 2003 管理パックは、次の目的では設計されていません。

  • SMS 1.2、SMS 2.0、SMS 2003 SP2 の監視の提供。

  • 混在する SMS 環境の監視。混在環境とは、SMS 1.2、SMS 2.0、および SMS 2003 を並行して稼働するような状況です。

  • SMS アドバンスト クライアントを実行している SMS クライアント専用コンピュータの限定された監視。

  • SMS 2003 をインストールし、設定を変更しないでそのまま管理できる監視ソリューションの提供。ルールしきい値は SMS 2003 インストールごとに異なっており、ユーザーは自身でルールをカスタマイズする必要があります。

ここでは、次のことについて説明します

この更新プログラムの新しい機能

推奨される知識

サポートされている SMS 構成

関連項目

概念

管理パックの監視シナリオ
SMS 2003 管理パックの展開

その他のリソース

SMS 2003 管理パックの操作タスクの実行
SMS 2003 管理パックのトラブルシューティング
Microsoft System Management Server 2003 管理パックの参照資料


この更新プログラムの新しい機能

Operations Manager 2007 用 Systems Management Server 2003 管理パックでは、保守モードを使用できます。保守モードは、クライアント コンピュータで SMS ソフトウェアが実行されている間はクライアント コンピュータによる Operations Manager アラートの送信を抑制するモードです。

SMS 2003 の保守モードの更新

System Management Server 2003 でソフトウェアをコンピュータに配布する際、ターゲット コンピュータで生成される規則ベースの Operations Manager アラートを一時的に無効にしなければならない場合があります。たとえば、ホットフィックスやセキュリティ修正プログラムをサーバーに展開するには、スレッドやサービスのシャットダウンが必要になることがあります。該当するサーバーのスレッドやサービスが管理パックで監視されている場合は、Operations Manager アラートが多数生成され、Operations Manager サーバーに過度な負荷がかかる可能性があります。

[このプログラムの実行中は MOM アラートを無効にする] チェック ボックスを使用すると、配布されたソフトウェアが終了するまで Operations Manager アラートを一時的に無効にすることができます。SMS 管理者は、このチェック ボックスを SMS パッケージ プログラムのプロパティで設定できます。このオプションを設定すると、クライアント コンピュータで該当するプログラムが実行されている間は、そのクライアント コンピュータを対象とするすべての管理パックについて、Operations Manager アラートが抑制されます。

このオプションがオンの場合、ターゲット コンピュータで提供情報が実行される際に、Operations Manager エージェントは保守モードになります。SMS エージェントには、Operations Manager エージェントのタイムアウト設定も用意されています。ターゲット コンピュータで提供情報の実行が完了すると、SMS クライアント エージェントはそのコンピュータで、Operations Manager エージェントの監視を再開します。これ以降にアラートをトリガするイベントが発生した場合は、通常どおり報告されます。

ターゲット コンピュータでソフトウェア配布プログラムを実行できなかった場合は、次のアクションが実行されます。

  • 配布プログラムからエラー コードが返された場合、SMS エージェントは配布プログラムが正常に実行された場合と同様に、Operations Manager エージェントの保守モードを解除します。

  • 配布プログラムが予期せず失敗し、あらかじめ定義されたタイムアウト期間内に SMS エージェントがエラー コードを受信しなかった場合、Operations Manager エージェントは保守モードを終了します。

SMS 2003 プログラムの保守モードの有効化

SMS 2003 プログラムの実行中にクライアント コンピュータで保守モードを有効にするには、次の手順を実行します。

SMS 2003 プログラムの保守モードを有効にするには

  1. Systems Management Server コンソールで、[Systems Management Server]、[サイト データベース (<サイト サーバー名>)]、[パッケージ] の順に移動します。

  2. 詳細ペインで、[プログラム] を右クリックし、[プロパティ] をクリックします。

  3. [プログラムのプロパティ] ダイアログ ボックスで、[MOM] タブをクリックします。

  4. [このプログラムの実行中は MOM アラートを無効にする] をオンにして、[OK] をクリックします。

SMS 2003 プログラムの保守モードを有効にしておくと、クライアント コンピュータは SMS 2003 パッケージが配布され、実行された時点で保守モードに入るようになります。

メモ
保守モードのタイムアウトは、[プログラムのプロパティ] ダイアログ ボックスの [必要条件] タブで [許可された最長実行時間] プロパティを選択して設定します。

SMS 2003 サイト トポロジ

Microsoft Operations Manager (MOM) 2005 の SMS 2003 の階層ダイアグラムに代わり、SMS 2003 サイト階層が導入されています。階層表示のトポロジ表示画面にサーバーの役割が表示されるようになりました。

構成スクリプトの削除

SMS の推奨バージョンは SMS 2003 SP2 以降であるため、構成スクリプトは削除されています。

SMS 2003 のレポート

SMS 2003 には、サイト システムの役割に基づくパフォーマンス カウンタおよびオブジェクト処理カウンタに基づくパフォーマンス カウンタ (DDR 関連のカウンタなど) に焦点を合わせた新しいレポートが用意されています。新しいレポートの詳細については、「SMS 2003 のレポート」を参照してください。

関連項目

概念

SMS 2003 のレポート

その他のリソース

SMS 2003 のスクリプト


推奨される知識

SMS 2003 管理パックを展開し操作するために、以下の知識とスキルを持っていることが推奨されます。

  • Operations Manager 2007 の監視機能についての実用的な知識。Operations Manager 2007 についての詳細は、Operations Manager 2007 Web ページ (http://go.microsoft.com/fwlink/?LinkID=83259) (英語の可能性あり) を参照してください。

  • Operations Manager 2007 の設計アーキテクチャ、および組織で展開されている設計アーキテクチャについての理解。

  • 『System Center Operations Manager 2007 展開ガイド』に説明されている、管理パック展開の推奨プロセスの熟知。

  • SMS の概念と技術用語に関する実用的な知識。SMS 2003 についての詳細は、SMS 2003 製品ドキュメントの Web ページ (http://go.microsoft.com/fwlink/?linkid=9502) (英語の可能性あり) を参照してください。

関連項目

概念

管理パックの監視シナリオ
SMS 2003 管理パックの展開

その他のリソース

SMS 2003 管理パックの操作タスクの実行


サポートされている SMS 構成

SMS 2003 および Systems Center Operations Manager 2007 の要件については、それぞれの展開ガイドに記載されています。SMS 2003 管理パックは、SMS 2003 を監視します。SMS 2003 SP2 以降を推奨します。SMS 2003 SP1 を実行するには、スタンプ スクリプトを実行する必要があります。

Operations Manager 2007 でソフトウェアの配布およびトポロジ マッピングを行う際にメンテナンス モードを有効にするには、SMS 2003 SP3 以降が必要です。

この SMS 2003 管理パックは、SMS 1.2、SMS 2、または Configuration Manager 2007 を監視しません。

関連項目

その他のリソース

Microsoft System Management Server 2003 管理パックの参照資料
SMS 2003 管理パックのトラブルシューティング


管理パックの監視シナリオ

Microsoft® Systems Management Server (SMS) 2003 は、SMS 2003 の監視のための新機能と改善された機能を提供します。以降のセクションでは、SMS 2003 管理パックがサポートする主要なシナリオとその機能について説明します。

サービスの可用性

サービス検索

可用性の監視

状態監視

エージェントレスの監視のサポート

パフォーマンスしきい値の監視

パフォーマンスの監視

重大な SMS ステータス メッセージの監視

サイト システムの監視

Executive のクラッシュ ダンプの監視

バックログの監視

全般的な稼働状態の監視

SMS 修正プログラム管理の監視

SMS サイト バックアップの監視

すべてのアラートに関する製品ナレッジ コンテンツ

すべての SMS 2003 サーバーおよびクライアントの役割のコンピュータ グループ

拡張監視

ソフトウェア配布プログラムの実行ステータス

サービスの可用性

サービスの可用性は、System Center Operations Manager 2007 のサービスの可用性機能と NT イベント システム ログのサービス コントロール マネージャ イベントの両方を使用して、SMS 2003 サービスの可用性を監視します。サービスの可用性の監視では、次のものが生成されます。

  • SMS サイト システムで SMS ベースのサービスが停止したときのアラート。

  • Windows Management Instrumentation (WMI) などの重要な SMS 依存サービスが、SMS サイト システムで停止または起動に失敗した場合のアラート。

  • Microsoft SQL Server™、インターネット インフォメーション サービス (IIS)、およびバックグラウンド インテリジェント転送サービス (BITS) などのその他の SMS 依存サービスが、SMS サイト システムで停止または起動に失敗した場合のアラート。

  • SMS サイト バックアップ サービスが開始および停止された場合のアラート。これにより、バックアップ期間を監視し、その他の SMS サービスからの停止イベントを SMS サイト バックアップに相関させることができます。

サービス検索

サービス検索は、管理されているコンピュータ上のデータ、サーバーの役割、およびコンポーネントを検出する処理です。サービス検索は、SMS サーバーと SMS アドバンスト クライアントに関する情報を返します。状態監視表示での SMS サーバーおよび SMS クライアントの役割の表示もサポートしています。

管理パックが展開されると、サーバー固有のサービス検索データが収集され、System Center Operations コンソールでの表示が開始されます。役割、コンピュータ グループ、および特定タスクのターゲット コンピュータを識別する必要のある機能は、初回のサービス検索データの収集が終了するまで使用できません。

SMS 2003 管理パックは次のイベント処理ルールを使用して、サービス検索スクリプトを起動します。

  • SMS クライアント\SMS クライアント - アドバンスト\SMS 2003 サービス検索

  • SMS サーバー\SMS サーバー - 共通\SMS 2003 サービス検索

スクリプトは、非同期時間指定プロバイダを使用して、既定では 24 時間ごとにサービス検索データを収集します。プロバイダは、次のことも実行します。

  • 管理パックの展開

  • 管理パックに対する構成の変更

  • Operations Manager 2007 エージェントの開始および停止

可用性の監視

このリリースの SMS 管理パックには 3 つの可用性レポートが用意されています。SMS 2003 サーバーの可用性レポート、SMS 2003 管理ポイントの可用性レポート、および SMS 2003 サイト サーバーの可用性レポートです。

管理ポイントの可用性レポートは、コンポーネントの稼働状態に基づく可用性レポートです。管理ポイントの可用性は、新しいアルゴリズム、新しいルール、および SMS 2003 Monitor Management Point Availability スクリプトに基づいています。

ここで紹介している新しいレポートを含むすべてのレポートは、OperationsManager データベースに対して実行されます。このため、以前のスクリプトより長いレポート期間を指定することができます (以前のスクリプトでは、OperationsManager データベースのストアド プロシージャが作成されるだけでした)。

サーバーの可用性の詳細については、「SMS 2003 のスクリプト」および「SMS 2003 のレポート」を参照してください。

状態監視

状態監視は、すべてのサーバーまたは特定のコンピュータ グループに限定されたサーバーの稼働状態のグラフィック表示を提供します。管理パックは、コンピュータ グループの特定の一覧を使用してこの機能をサポートします。サーバーの役割およびコンポーネントはサーバー検索を通じて管理され、コンポーネントの稼働状態はサービスの可用性、パフォーマンスしきい値、および管理ポイントの稼働状態に関するルール セットによって管理されます。

下の表には、SMS コンポーネントで監視される稼動状態が色分けして示されています。

SMS サーバーの状態監視

SMS コンポーネント | 緑 (正常) | 黄 (警告) | 赤 (重大)
サイト サーバー (SS) | ○ | ○ | ○
管理ポイント (MP) | ○ | ○ | ○
サイト データベース (DB) | ○ | ○ | ○
配布ポイント (DP) | ○ |  |
サーバー ロケータ ポイント (SLP) | ○ |  | ○
センダ | ○ |  | ○
レポート ポイント (RP) | ○ |  | ○
プロバイダ | ○ |  | ○
クライアント アクセス ポイント (CAP) | ○ |  | ○
パフォーマンス | ○ | ○ | ○
メモ
配布ポイント コンポーネントの状態を変更する監視ルールはないため、そのコンポーネントが存在する場合は、緑色の状態だけが報告されます。配布ポイント コンポーネントが存在しない場合、稼働状態はコンソールには表示されません。

SMS クライアントの状態監視

SMS コンポーネント | 緑 (正常) | 黄 (警告) | 赤 (重大)
クライアント サービス | ○ |  | ○

エージェントレスの監視のサポート

SMS 2003 管理パックは、次に示す機能を除き、エージェントレスで管理されたコンピュータの監視をサポートします。

  • 重大な SMS ステータス メッセージの監視

  • サイト システム ステータスの監視

  • トポロジ

上記の機能をサポートするスクリプトは、次のとおりです。

  • SMS 2003 SMS ステータス メッセージの監視

  • SMS 2003 サイト システム サマライザの監視

  • SMS 2003 サーバー トポロジ : 検索

これらのスクリプトは、SMS 名前空間にアクセスするために、SMS プロバイダに対してローカルで実行する必要があります。スクリプトが SMS 名前空間を見つけられなかった場合は、スクリプト エラー イベントが発生します。

パフォーマンスしきい値の監視

パフォーマンス レベルを下げると、遅延が生じ、時間、パフォーマンス、データの正確度に関するカスタマ サービス レベル アグリーメント (SLA) に影響することがあります。SMS インフラストラクチャ内の重大なパフォーマンス問題を検出して解決することが重要です。パフォーマンスしきい値の監視は、次の場合にアラートを生成します。

  • SMS サイト システム上の CPU、ページング ファイル、およびメモリに関連するコンピュータ全般の稼働状態メトリックが特定のしきい値を超えた場合。

  • Microsoft SQL Server™ ユーザー接続の総数がしきい値を超えた場合。

  • SMS ファイル (スケジューラ ジョブ、送信要求、ソフトウェア メータリング レコード、データ探索レコード (DDR)、ソフトウェア インベントリおよびハードウェア インベントリのレコードなど) の総数が SMS サイト サーバー受信トレイの特定のしきい値を超えた場合。

  • SMS 管理ポイント メッセージ キュー内のステータス メッセージ、DDR、ソフトウェア インベントリ、およびハードウェア インベントリに関連する SMS メッセージの総数が、特定のしきい値を超えた場合。

パフォーマンスの監視

パフォーマンスの監視は、バックログ、処理率、および重要な SMS オブジェクトの合計数に関する傾向を観察して、問題を特定し解決するのに役立ちます。パフォーマンスの傾向では、Operations Manager 2007 のビューとレポートを使用して､次の傾向をグラフィカルに監視します。

  • スケジューラ ジョブ、送信要求、ソフトウェア メータリング レコード、DDR、ハードウェア インベントリ、ソフトウェア インベントリ、および SMS サイト サーバーのステータス メッセージに関する受信トレイ内のバックログ ファイル。

  • スケジューラ ジョブ、送信要求、ソフトウェア メータリング レコード、DDR、ハードウェア インベントリ、ソフトウェア インベントリ、および SMS サイト サーバーのステータス メッセージの処理率。

  • スケジューラ ジョブ、送信要求、ソフトウェア メータリング レコード、DDR、ハードウェア インベントリ、ソフトウェア インベントリ、および SMS サイト サーバーのステータス メッセージの総数。

  • DDR、ハードウェア インベントリ、ソフトウェア インベントリ、ソフトウェア メータリング、ステータス メッセージ、および SMS 管理ポイント サーバー メッセージ キューのその他の SMS オブジェクトに関するメッセージのバックログ。

  • DDR、ハードウェア インベントリ、ソフトウェア インベントリ、ソフトウェア メータリング、ステータス メッセージ、および SMS 管理ポイント サーバー メッセージ キューのその他の SMS オブジェクトの処理率。

  • DDR、ハードウェア インベントリ、ソフトウェア インベントリ、中継、および SMS 管理ポイント サーバー メッセージ キューのステータス メッセージの総数。

  • SMS サイト データベース サーバー上の SQL Server ユーザー接続の総数。

  • SMS サイト システム上の CPU、ページング ファイル、およびメモリに関連するコンピュータ全般の稼働状態メトリック。

  • 実行中の SMS Executive スレッドの総数。

  • IIS に対する ISAPI 拡張要求の割合。

重大な SMS ステータス メッセージの監視

SMS インフラストラクチャは、SMS ステータス メッセージを生成します。サーバー関連の重大な SMS ステータス メッセージを特定し、それらをすぐに解決することが重要です。通常、これらは、可用性、パフォーマンス、構成、および SMS インフラストラクチャ全体の稼働状態における問題を示しています。

重大な SMS ステータス メッセージの監視では、SMS サイト役割の稼働状態にとって重大なステータス メッセージ (コンポーネントのインストール、データベース接続、サイト接続など) を検出したときに、アラートを生成します。SMS サイト データベースは、重大な SMS ステータス メッセージが存在していないかどうか、30 分ごとにスキャンされます。

サイト システム ステータスの監視

SMS は、毎正時に 1 回ずつ SMS サイト システムをポーリングするサイト システム ステータス サマライザを使用して、サイト システムの基本稼働状態を定期的に監視します。この機能の利点を活かすには、このステータスに迅速に対処し、SMS の機能性の低下を防ぐ必要があります。サイト システム ステータス監視は、SMS サイト システムの稼働状態にとって重大な SMS サイト システム サマライザ ステータスを監視し、それが検出されたときにアラートを生成する機能を提供します。監視対象のステータス メッセージには、SMS サイト システムがダウンしている、サーバーがデータベース領域またはログ領域が不足している SQL Server を実行している、SMS サイト システムの物理ディスク空き領域が不足している、などのメッセージも含まれています。

Executive のクラッシュ ダンプの監視

SMS Executive サービスの障害は SMS の可用性に影響するため、クラッシュ ダンプが発生した場合にそれを把握し、根本原因を調査することが重要です。SMS Executive サービスで障害が発生すると、SMS\Logs\CrashDumps ディレクトリにクラッシュ ダンプ ログのサブディレクトリが作成されます。このサブディレクトリの作成が監視され、SMS Executive サービスに依存しているすべての SMS サーバーの役割に対してアラートが生成されます。

SMS 2003 Monitor SMS Executive Crash Dumps スクリプトでは、最新のクラッシュ ダンプのみが報告されます。これは、最後にクラッシュ ダンプが発生したのがどれほど前であろうと関係ありません。SMS Executive をいったんアンインストールして再インストールした場合も含め、このスクリプトが初めて実行されたとき以降で最新のクラッシュ ダンプが報告されます。

[SMS Executive に基づく Microsoft SMS 2003 コンポーネント サーバー] ルール グループに、以下の関連するルールが存在します。

  • SMS 2003 クラッシュ ダンプ : SMS Executive の監視

[SMS 2003 クラッシュ ダンプ : SMS Executive の監視] は、[SMS 2003 Schedule every 60 minutes synchronize at 00:10] 時間指定イベント プロバイダを使用してこのスクリプトを起動します。このルールの [Knowledge] プロパティ ページに概要情報が表示されます。

  • SMS 2003 クラッシュ ダンプ : SMS Executive スクリプト エラーの監視

[SMS 2003 クラッシュ ダンプ : SMS Executive スクリプト エラーの監視] は、発生する可能性があるスクリプト エラー イベントを監視し、発生した場合にアラートを生成します。スクリプト エラー イベントは 1 つしかありません (1102)。これにより、すべてのスクリプト エラーが報告されます。このルールの [Knowledge] プロパティ ページに、アラートの解決に関する情報が表示されます。

  • SMS 2003 クラッシュ ダンプ : SMS Executive クラッシュ

[SMS 2003 クラッシュ ダンプ : SMS Executive クラッシュ] は、クラッシュ ダンプ イベントを監視し、発生した場合にアラートを生成します。このルールの [Knowledge] プロパティ ページに、アラートの解決に関する情報が表示されます。

バックログの監視

バックログにより、時間、パフォーマンス、およびデータの正確度に関するカスタマ サービス レベル アグリーメント (SLA) に影響する遅延が発生します。SMS インフラストラクチャ内の重大なパフォーマンス問題を迅速に検出し解決することが重要です。一定期間に、バックログが次のものに関するしきい値を超えた場合は、アラートが生成されます。

  • SMS サイト サーバー受信トレイ内の SMS ファイル (スケジューラ ジョブ、送信要求、ソフトウェア メータリング レコード、データ探索レコード (DDR)、ソフトウェア インベントリおよびハードウェア インベントリのレコードなど) の総数。

  • SMS サイト サーバー キュー内の SMS オブジェクト (スケジューラ ジョブ、送信要求、ソフトウェア メータリング レコード、データ探索レコード (DDR)、ソフトウェア インベントリおよびハードウェア インベントリのレコードなど) の総数。

SMS 管理ポイント メッセージ キュー内のステータス メッセージ、DDR、ソフトウェア インベントリ、およびハードウェア インベントリに関連する SMS メッセージの総数。

全般的な稼働状態の監視

全般的な稼働状態の監視は、SMS サーバーの稼働状態メトリックが一定期間内に特定のしきい値を上回ったときにアラートを生成します。全般的な稼働状態の監視では、次のメトリックを調べます。

  • 3 時間で 95% のプロセッサ時間

    • Smsexec

    • Ccmexec

    • 合計

  • 3 時間で 98% のページング ファイル使用率

SMS 修正プログラム管理の監視

SMS 管理者は、SMS 修正プログラム管理機能を使用して、企業内のクライアントおよびサーバー コンピュータに最新のセキュリティ更新プログラムを適用して最新の状態に維持します。修正プログラム管理の監視では、SMS 修正プログラム管理の処理および構成の失敗を検出します。SMS 修正プログラム管理の監視では、次の場合にアラートを生成します。

  • SMS 修正プログラム管理同期プロセスに失敗した。

  • SMS 修正プログラム管理プロセスが更新プログラムで SMS 配布ポイントを更新できない。

SMS サイト バックアップの監視

SMS 2003 バックアップがいつ起動、完了、または失敗したかを把握しておくと、SMS 管理者がバックアップ処理を監査するときに役立つ場合があります。SMS バックアップを定期的に実行するようにスケジュールして、SMS のデータ、ポリシー、および構成をバックアップすることができます。このバックアップ プロセスの失敗を監視し、修正措置をとることが重要です。SMS バックアップが成功した場合でも、このプロセスは SMS サイト コンポーネント マネージャ、SMS Executive、および SMS SQL モニタ サービスを停止および起動するため、サービスの可用性に影響を及ぼします。バックアップ プロセス中はこれらのサービスの停止に関するアラートが抑制されるため、SMS バックアップを監視すると、これらのサービスの既知のダウンタイムを追跡するときに役立ちます。次のルールが SMS サイト バックアップの監視をサポートしています。

  • SMS 2003 サービスの実行停止 : SMS_SITE_BACKUP

  • SMS 2003 サービスの実行開始 : SMS_SITE_BACKUP

  • SMS 2003 ステータス : サイト バックアップは正常に完了しました

  • SMS 2003 ステータス : サイト バックアップに失敗しました

すべてのアラートに関する製品ナレッジ コンテンツ

管理者は、問題を具体的に特定してそれを解決するときに、すべてのアラートに関して製品ナレッジ コンテンツを参照できます。製品ナレッジ コンテンツにアクセスするには、ルール名を右クリックし、[プロパティ]、[製品ナレッジ] タブの順にクリックします。

すべての SMS 2003 サーバーおよびクライアントの役割のコンピュータ グループ

コンピュータ グループの解決は、現在では、特定の SMS サーバーおよびクライアントの役割に設定されています。これは、管理者に、Operations Manager 2007 エージェントへのルール レプリケーションを管理するためのより強力な制御機能を提供します。管理者は、既定のコンピュータ グループを無効にしたり、既定のコンピュータ グループとコンピュータ属性に基づいて新しいコンピュータ グループを定義したりできます。

拡張監視

SMS 2003 管理パックで提供されているルールは、SQL Server、IIS、および Microsoft Windows® 2000 と Windows Server® 2003 Base Operating System 各管理パックのための、基本サービス、パフォーマンス測定、およびパフォーマンスしきい値の監視を対象としています。これらの管理パック用に SMS 2003 管理パックの基本サポートを有効にすることも、無効な設定値をそのままにして、他の管理パック内の適切なルールを有効にすることもできます。

  • SQL Server 管理パックを使用すると、SMS サイト データベース サーバーおよび SQL Server と依存関係がある管理ポイントの監視を拡張できます。

  • IIS 管理パックを使用すると、レポート ポイント、管理ポイント、およびサーバー ロケータ ポイントで IIS を監視できます。IIS 管理パックは、BITS が有効な配布ポイントを監視することもできます。

  • Microsoft Windows 2000 および Windows Server 2003 Base Operating System 管理パックを使用すると、CPU、ディスク、メモリの統計情報など、Windows 基本コンポーネントを監視できます。

その他にも、SMS 2003 管理パックではルールは提供されていないが、SMS 2003 インフラストラクチャの監視を拡張する Windows ネットワーク負荷分散や Windows Active Directory® などの管理パックがあります。

  • 拡張性のために、ネットワーク負荷分散を使用して SMS 階層内の複数の管理ポイントをサポートする場合は、Windows ネットワーク負荷分散管理パックを使用します。

  • Active Directory インフラストラクチャの稼働状態を監視する場合は、Active Directory 管理パックを使用します。

環境に複数の管理パックを展開すると、両方の管理パックに存在するルールに基づいて重複したアラートを受け取ることがあります。重複した監視ルールを無効にすると、展開した管理パックの状態表示の正確度に影響する場合があります。重複したアラートの受信と、展開する各管理パックの状態監視の正常な動作のどちらをとるかを十分に考慮する必要があります。追加で展開した管理パックに応じ、このような重複するルールを確認して、環境で有効にするルールを特定する必要があります。これらの管理パックをインストールした後、それらが必要に応じてカスタマイズされ、正しく構成され、適切なルールが有効になっていることを確認します。

ソフトウェア配布プログラムの実行ステータス

SMS アドバンスト クライアントは、管理パックを通じてプログラムの障害を報告できます。

管理者は、[プログラムのプロパティ] ダイアログ ボックスの [MOM] タブで [このプログラムが失敗した場合は MOM アラートを生成する] チェック ボックスをオンにできます。

手順

SMS 2003 プログラムの実行に失敗した場合に Operations Manager 2007 のアラートが生成されるようにするには、次の手順を実行する必要があります。

SMS 2003 プログラムに対して Operations Manager 2007 のアラートを有効にするには

  1. Systems Management Server コンソールで、[Systems Management Server] / [サイト データベース - <サイト サーバーの名前>] / [パッケージ] に移動します。

  2. 詳細ペインで、[プログラム] を右クリックし、[プロパティ] をクリックします。[プログラムのプロパティ] ダイアログ ボックスが表示されます。

  3. [MOM] タブをクリックします。

  4. [このプログラムが失敗した場合は MOM アラートを生成する] チェック ボックスをオンにします。[OK] をクリックします。

関連項目

概念

SMS 2003 管理パックの展開

その他のリソース

Microsoft System Management Server 2003 管理パックの参照資料


SMS 2003 管理パックの展開

Microsoft® Systems Management Server (SMS) 2003 管理パックを展開する前に、Operations Manager 2007 Web ページ (http://go.microsoft.com/fwlink/?LinkID=83259) にある Microsoft Operations Manager 2007 展開ガイド (英語の可能性あり) を参照してください。このセクションでは、Operations Manager 管理パックを展開するための補足的な手順について説明します。

SMS 2003 管理パックを展開するには、次の手順を完了する必要があります。

  • Operations Manager 2007 エージェントをすべての SMS サーバー コンポーネント コンピュータに展開します。

メモ
Operations Manager 2007 メンテナンス モードまたはトポロジ マッピングが必要な場合、SMS 2003 管理パックのインポートまたは Operations Manager 2007 エージェントのインストールを行う前に、SMS 2003 SP3 を展開する必要があります。

  • SMS 2003 管理パックを Operations Manager 2007 構成グループにインポートします。

  • Operations Manager 2007 エージェントが他のコンピュータのプロキシとして機能するように、SMS プロバイダおよび SMS サイト データベース サーバーを構成します。

  • 推奨されているテストとパイロット テストのタスクを完了します。

  • 推奨されている調整タスクを完了します。

このセクションの内容

Operations Manager 2007 エージェントの展開

管理パックのテストとパイロット テスト

管理パックのカスタマイズ

関連項目

概念

管理パックの監視シナリオ

その他のリソース

Systems Management Server 2003 管理パックの概要
SMS 2003 管理パックの操作タスクの実行
SMS 2003 管理パックのトラブルシューティング
Microsoft System Management Server 2003 管理パックの参照資料


Operations Manager 2007 エージェントの展開

Operations Manager エージェントは、Operations Manager が監視する各コンピュータ上で実行されます。SMS 2003 管理パックが監視するコンピュータ グループを表示する方法については、このガイドの「SMS 2003 のコンピュータ グループ」を参照してください。Operations Manager 2007 エージェントは管理されたコンピュータの監視データを収集し、それらのデータにルールを適用します。その後、結果のデータを Data Consolidator Agent Manager (DCAM) に送信します。エージェント コンピュータの監視機能は、Operations Manager 2007 サービス (HealthService.exe)、Operations Manager 2007 ホスト (MonitoringHost.exe)、およびエージェント アクション アカウントによって提供されています。

Operations Manager 2007 エージェントを展開するには、Operations Manager 2007 インストール ウィザードまたは SMS ソフトウェア配布を使用できます。Operations Manager 2007 エージェントの展開および Operations Manager 2007 インストール ウィザードの使用に関する詳細については、『Microsoft Operations Manager 2007 Deployment Guide』の「Discovering Computers and Deploying MOM Agents」を参照してください。詳細については、Operations Manager 2007 Web ページ (http://go.microsoft.com/fwlink/?LinkID=83259) (英語の可能性あり) を参照してください。

メモ
SMS プロバイダ コンピュータで Operations Manager 2007 エージェントを実行する際は、LocalSystem アカウントを使用するようお勧めします。または、SMS 2003 WMI 名前空間ルートの root\cimv2、root\sms、および SMS レジストリ キーとサブキーにアクセス可能な権限を持つアカウントを使用してください。

使用する環境でエージェントレスな管理を使用できるかどうかを特定するには、「管理パックの監視シナリオ」の「エージェントレスの監視のサポート」を参照してください。

エージェント コンピュータを低い特権で構成するシナリオ

エージェント コンピュータの監視機能は、Operations Manager 2007 サービス (HealthService.exe)、Operations Manager 2007 ホスト (MonitoringHost.exe)、およびエージェント アクション アカウントによって提供されています。Microsoft Windows® 2000 では、アクション アカウントがローカル Administrators グループのメンバである必要があります。Microsoft Windows™ 2003 の場合、特定の状況で、低い特権のアカウントをエージェントのエージェント アクション アカウントとして使用できます。ただし、Operations Manager 2007 サービスとそのホスト プロセスが実行でき、かつ SMS 2003 管理パックの機能を実行する権限とアクセス許可を持つアクション アカウントとユーザー コンテキストを構成するには、エージェント コンピュータを手動で大幅に構成する必要があります。Microsoft Windows Server™ 2003 の場合、エージェント アクション アカウントが、次の最低限のユーザー権利とアクセス許可を持っている必要があります。

  • ローカル ユーザー グループのメンバ

  • Windows イベント ログへのアクセス

  • "監査とセキュリティ ログの管理" アクセス許可 (SeSecurityPrivilege)

  • "セキュリティ監査の生成" アクセス許可 (SeAuditPrivilege)

  • "ローカル ログオンを許可する" アクセス許可 (SeInteractiveLogonRight)

低い特権のシナリオでは、SMS 2003 管理パックで、エージェント アクション アカウントとして使用されるアカウントに追加の権限とアクセス許可が必要です。次の表に、手動で構成する必要があるアクセス権の詳細を示します。

SMS 2003 管理パックに必要なアクセス権の種類

リソース | アクセス権の種類 | 手順
Windows イベント ログ | 読み取り | ローカルまたはグローバル ポリシーを使用し、アクション アカウントに "監査とセキュリティ ログの管理" 特権を付与する必要があります。
SMS レジストリ キー | 読み取り | HKLM\Software\Microsoft\SMS アクション アカウントをレジストリ プロパティに追加し、すべてのサブキーによって継承される読み取りアクセス権を付与します。
Win32 サービス レジストリ キー | 読み取り | HKLM\System\CurrentControlSet\Services アクション アカウントをローカル ユーザー グループに追加します。
スクリプトによって生成された一時ファイル | 読み取りと書き込み | %Windir%\Temp アクション アカウントをローカル ユーザー グループに追加します。 .
スクリプトによって生成されたログ ファイル | 読み取りと書き込み | %Windir%\Microsoft Operations Manager アクション アカウントをフォルダ プロパティに追加します。
SMS ログ ファイル | 読み取り | \SMS\Logs アクション アカウントをフォルダ プロパティに追加します。
WMI 名前空間 | 読み取り | root および root\cimv2 操作は不要です。
SMS WMI 名前空間 | 読み取り | 操作は不要です。
SMS WMI クラス | 読み取り | SMS_Site SMS_R_System SMS_SystemResourceList SMS_SiteSystemSummarizer アクション アカウントを全インスタンスのクラスに追加します。
既定のインスタンスに対するセキュリティ ログイン権限 | アクセスの許可 | 管理された SQL Server コンピュータ上にある既定のインスタンスのアクション アカウントに対し、セキュリティ ログインするためのアクセス許可権限を付与する必要があります。SQL Server Enterprise Manager で、instancename\Security\Logins のノードにアクション アカウントを追加します。
既定のインスタンス上にある Master データベースへのアクセス (SMS サイト データベースの特定に必要) | 許可 | 管理された SQL Server コンピュータ上にある既定のインスタンスで、アクション アカウントに対し、Master データベースへのアクセス許可を付与する必要があります。SQL Server Enterprise Manager で、instancename\Databases\Master\Users のノードにアクション アカウントを追加します。 この新しいユーザーに関連付けられている既定のアクセス許可は、いずれも削除しないでください。
既定のインスタンス上にある SMS サイト データベースへのアクセス | 許可 | 管理された SQL Server コンピュータ上にある既定のインスタンスで、アクション アカウントに対し、SMS サイト データベースへのアクセス許可を付与する必要があります。SQL Server Enterprise Manager で、instancename\Databases\<SMS site>\Users のノードにアクション アカウントを追加します。 この新しいユーザーに関連付けられている既定のアクセス許可は、いずれも削除しないでください。

関連項目

概念

管理パックのテストとパイロット テスト
管理パックのカスタマイズ

その他のリソース

SMS 2003 管理パックのトラブルシューティング
SMS 2003 の既知の問題


管理パックのテストとパイロット テスト

このセクションでは、『Microsoft Operations Manager 2007 Deployment Guide』で説明されている管理パックのテストに関する一般的な推奨事項に加え、SMS 2003 管理パックに適したテストとパイロット テストのタスクを示します。詳細については、Operations Manager 2007 Web ページ (http://go.microsoft.com/fwlink/?LinkID=83259) (英語の可能性あり) を参照してください。

テスト タスク

  • SMS 2003 コンピュータ グループに、SMS 2003 を実行するコンピュータのみが含まれていることを確認します。

  • 関連するルールを有効にした後、Operations Manager 2007 のビューとレポートが適切に機能していることを確認します。これには、SMS 処理率と SMS バックログに関連するビューが含まれます。

  • 既定では、IIS や SQL Server の管理パックなど、他の管理パックに関連する一部のルールが SMS 2003 管理パックで無効になっています。追加で展開した管理パックによっては、無効になっているルールを確認し、使用環境で有効にする必要のあるルールがないかどうかを調べてください。

  • 既定では、エージェントの CPU、メモリ、およびネットワーク リソースへの影響を最小限に抑えるために、パフォーマンス測定ルールはすべて無効になっています。エージェントをより詳細に監視するには、これらのルールを有効にすることができます。

  • SMS プロバイダ コンピュータ (SMS サイト データベース サーバー) で実行される SMS スクリプト、または SMS サイト データベースにアクセスする SMS スクリプトの一部は、エージェントレス モードでは動作しません。Microsoft SMS 2003 プロバイダ コンピュータ グループおよび Microsoft SMS サイト データベース サーバー コンピュータ グループ内の全コンピュータが、エージェントに管理されたコンピュータとして構成されていることを確認します。また、これらのスクリプトの中にはイベントをプロキシ化するものがあるため、これらのエージェントでプロキシ化が有効になっていることを確認します。

パイロット テストのタスク

  • 以前のバージョンから SMS 2003 管理パックへ正常に展開またはアップグレードできたことを確認します。

  • パフォーマンスしきい値の [ヘルス モニタ] ビューを使用し、使用する環境のカスタムしきい値を確認し、編集します。

  • パフォーマンス ルールは、それらのルールが Operations Manager 2007 パフォーマンスに与える影響を調べる段階でのみ有効にしてください。

  • SMS 2003 コンピュータ グループに、SMS 2003 を実行するコンピュータのみが含まれていることを確認します。

  • 関連するルールを有効にした後、Operations Manager 2007 のビューとレポートが適切に機能していることを確認します。これには、SMS 処理率、処理総数、および SMS バックログに関連するビューが含まれます。

  • 既定で、他の管理パックに関連するルールは、一部無効になっています。追加で展開した管理パックによっては、無効になっているルールを確認し、使用環境で有効にする必要のあるルールがないかどうかを調べてください。

  • 既定では、エージェントの CPU、メモリ、およびネットワーク リソースへの影響を最小限に抑えるために、一部のパフォーマンス測定ルールが無効になっています。エージェントをより詳細に監視するには、これらのルールを有効にすることができます。

  • SMS 2003 スクリプト実行ベースのイベントが生成されていないことを確認します。これらのイベントが生成される場合、通常はスクリプトのアクセス許可に関する問題が発生していることを示します。

  • DCAM と SQL Server のサイジングが、運用負荷に十分対応できることを確認します。

  • 操作プロセスと人員の要件を確認します。

  • ポケットベルと電子メールによる通知が正しく動作していることを確認します。

  • Operations Manager 2007 に対して、適切に動作するために十分なアクセス許可が付与されており、必要以上に付与されていないことを確認します。

  • Operations Manager 2007 エージェントを LocalSystem アカウントで実行するよう指定されていない場合は、最小限のセキュリティ権限が付与されていることを確認します。詳細については、このガイドの「Operations Manager 2007 エージェントの展開」にある「エージェント コンピュータを低い特権で構成するシナリオ」を参照してください。

  • [State] ビューに、SMS サーバーと SMS クライアントの役割が表示されていることを確認します。これらの各役割をホストしているコンピュータをクリックし、インスタンス ウィンドウにそれらのコンポーネントが表示されることを確認します。

  • SMS 管理コンソールのタスクをクリックし、それらのタスクが動作することを確認します。タスクが動作しない場合は、SMS 2003 SP2 管理コンソールがインストールされていること、またログオン ユーザーがログオフしていることを確認してください。次に、コンソールのインストールが完了した後にログオンしてください。

  • [State] ビューで、SMS サーバーと SMS クライアントをクリックし、[Roles] ページに適切な役割とプロパティ データが表示されていることを確認します。

  • [監視] で、[Microsoft Systems Management Server (SMS) 2003] に移動し、[SMS 2003 Site Hierarchy Diagram] をクリックします。Operations Manager 2007 エージェントが SMS プロバイダにローカルでインストールされているサイトについて、すべてのサイト システムが表示されていることを確認します。サイト システムが表示されない場合は、SMS 管理コンソールで、そのサイト システムがサイトで検出されており、[すべてのシステム] コレクションに表示されているかどうかを確認します。

パイロット テストの完了後、SMS 2003 管理パックに加えた変更内容をバックアップするため、管理パックをエクスポートします。

関連項目

概念

管理パックのカスタマイズ
Operations Manager 2007 エージェントの展開

その他のリソース

SMS 2003 管理パックのトラブルシューティング
SMS 2003 の既知の問題


管理パックのカスタマイズ

組織のビジネス ニーズに適した監視を行えるように、SMS 2003 管理パックをカスタマイズできます。既存のルールで組織のニーズを満たせない場合、それらのルールを変更したり、新しいルールを作成したりできます。

メモ 変更を加える前に、必ず SMS 2003 管理パックのバックアップを行ってください。Operations Manager 2007 管理パック エクスポート ウィザードを使用すると、出荷時の管理パックをバックアップできます。

次のカスタマイズを行うことができます。

  • 上書きにより、ルールを有効または無効にする。

  • 新しいルールを作成する。

  • アラート条件、アラート レベル、およびアラート抑制を変更する。

  • ルールのカスタムしきい値を設定する。パフォーマンスしきい値ルールは、すべて設定可能です。既定のしきい値が最適ではない場合、不要なアラートが生成されたり、しきい値が使用環境にとって高すぎるためにアラートが生成されなかったりする可能性があります。

  • 受信トレイ監視イベント ルールしきい値およびポーリング間隔を設定する。ポーリング間隔は上書きし、しきい値の場合は XML ビューを編集します。

  • 新しい受信トレイ監視イベント ルールを追加する。新しい受信トレイ監視ルールを追加するには、既定の管理パックで新しいルールを作成し、スクリプト入力パラメータ (FileCountThreshold および InboxDirectoryName) の上書き指定を作成します。

  • 上書きにより、パフォーマンス計測のポーリング間隔を設定する。

  • 企業のナレッジにコンテンツを追加する。

  • アラートの応答をカスタマイズする。カスタマイズは、応答を変更したり、ルールに新しい応答を作成したり、それらのアラートにアラート処理ルールを追加したりすることで行えます。

  • エージェント、Operations Manager 2007 を実行しているサーバー、および大量のデータを生成するためにパフォーマンスの問題が発生する可能性のあるデータベースで、パフォーマンス計測ルールを有効にする。既定ではパフォーマンス計測ルールが無効になっています。これは、Operations Manager 2007 のパフォーマンスに与える影響を確認しながらルールを追加できるようにするためです。各パフォーマンス ルールを確認し、それらのルールを徐々に適用することによって、パフォーマンス ルールが Operations Manager 2007 のパフォーマンスやデータベースのサイズに与える影響を見極めることができるようにしてください。

  • 受信トレイ監視イベント ルールおよび関連ルールのパラメータを設定する。上書き指定を作成することで、FileCountThreshold と InboxDirectoryName, いう 2 つのスクリプトを変更します。

  • ルールを確認し、環境に適しているかどうかを調べる。既定で、他の管理パックに関連するルールは、一部無効になっています。追加で展開した管理パックによっては、無効になっているルールを確認し、使用環境で有効にする必要のあるルールがないかどうかを調べてください。

管理パックのカスタマイズ、およびカスタマイズした管理パックをエクスポートする方法の詳細については、Operations Manager 2007 ヘルプの「About Management Packs in Operations Manager 2007」および「How to Export Management Pack Customizations」のトピックを参照してください。

受信トレイの監視

Operations Manager 2007 エクスポート ウィザードを使用すると、ユーザー既定の管理パックに変更を加える前に、既存の変更内容を保存できます。

受信トレイ監視ルールの構成

これらのルールをセントラル、プライマリ、およびセカンダリ サイト サーバーに展開するには、SMS サイト サーバー - 共通のルールに基づいて、管理パックで新しいルールを作成する必要があります。その後、それらのルールをサイト サーバーの適切な処理ルール グループに割り当て、しきい値を変更したり、ルールを有効にしたりできます。

  • SMS 2003 受信トレイ : 受信トレイを監視します

  • SMS 2003 受信トレイ : 受信トレイのスクリプト エラーを監視します

  • SMS 2003 受信トレイ : しきい値を超えました

[SMS 2003 受信トレイ : しきい値を超えました] イベント処理ルールは、[SMS 2003: Monitor Inbox script error] スクリプトが生成するイベントを監視します。指定したしきい値を超えた受信トレイごとに、固有のアラートが生成されます。

このスクリプトの既定のしきい値は、受信トレイ 1 つあたり 10,000 ファイルです。このスクリプト パラメータまたは他のスクリプト パラメータの既定の管理パックで、この値の上書き指定を作成できます。このしきい値を超えると、"しきい値を超えました" イベントが生成されます。各プロセスが正常に機能する場合に生じる 1 日あたりの予想サーバー負荷を計算し、許容できるバッファ率を追加することで、しきい値の設定を変更できます。受信トレイ監視ルールは、既定では 1 日に 1 回実行され、午前 1 時から開始して 15 分単位で増やすことができます。パフォーマンスへの影響を最小限に抑えるため、この間隔は変更しないようお勧めします。変更が必要な場合は、受信トレイ監視ルールの間で、スクリプトの実行が重複しないようにしてください。

次の表に、受信トレイ監視ルール、既定のしきい値、および SMS Executive プロバイダで監視される受信トレイを示します。

SMS Executive 受信トレイの監視

受信トレイ監視ルール名 | 既定のしきい値 | 受信トレイ名
SMS 2003 受信トレイ : 受信トレイのスクリプト エラーを監視します | なし | なし
SMS 2003 受信トレイ : しきい値を超えました | なし | なし
SMS 2003 受信トレイ : auth\dataldr.box を監視します | 10000 | Inboxes\auth\dataldr.box
SMS 2003 受信トレイ : auth\ddm.box を監視します | 10000 | Inboxes\auth\ddm.box
SMS 2003 受信トレイ : auth\sinv.box を監視します | 10000 | Inboxes\auth\sinv.box
SMS 2003 受信トレイ : compsumm.box\repl を監視します | 10000 | Inboxes\ compsumm.box\repl
SMS 2003 受信トレイ : dataldr.box を監視します | 10000 | Inboxes\ dataldr.box
SMS 2003 受信トレイ : ddm.box を監視します | 10000 | Inboxes\ ddm.box
SMS 2003 受信トレイ : despoolr.box\receive を監視します | 10000 | Inboxes\despoolr.box\receive
SMS 2003 受信トレイ : offermgr.box\INCOMING を監視します | 10000 | Inboxes\offermgr.box\INCOMING
SMS 2003 受信トレイ : offersum.box\repl を監視します | 10000 | Inboxes\ offersum.box\repl
SMS 2003 受信トレイ : replmgr.box\incoming を監視します | 10000 | Inboxes\replmgr.box\incoming
SMS 2003 受信トレイ : schedule.box\outboxes\LAN を監視します | 10000 | Inboxes\ schedule.box\outboxes\LAN
SMS 2003 受信トレイ : statmgr.box\statmsgs を監視します | 10000 | Inboxes\statmgr.box\statmsgs
SMS 2003 受信トレイ : swmproc.box\usage を監視します | 10000 | Inboxes\swmproc.box\usage

受信トレイ監視イベント ルールの上書き手順

受信トレイ監視イベント ルールを上書きする前に、Operations Manager 2007 サイト サーバーは、[Microsoft SMS 2003 Site Servers] という種類の SMS 2003 サイト サーバー オブジェクトを検索する必要があります。

受信トレイ監視イベント ルールを上書きするには

  1. Operations Manager 2007 のオペレータ コンソールで、[Authoring] をクリックします。

  2. [Authoring]、[Management Pack Objects]、[Rules] の順に移動します。

  3. [Microsoft SMS 2003 Site Servers] を選択します。

  4. [SMS 2003 受信トレイ : schedule box\requests を監視します] などの適切な SMS 2003 受信トレイ監視イベント ルールを右クリックし、[Overides]、[Override the Rule] の順に選択して、[For all objects of type: Microsoft SMS 2003 Site Server] をクリックします。

  5. [Override Properties] で、[Enabled] 上書き指定チェックボックスをオンにし、[Override Setting] を [True] に設定します。

  6. [Override Properties] で、[FileCountThreshold] 上書き指定チェックボックスをオンにし、[Override Setting] を目的のしきい値に設定します。

  7. [OK] をクリックします。[OK] をクリックします。変更したしきい値がサーバーに配布されます。

パフォーマンス カウンタのしきい値の監視を編集する手順

パフォーマンス カウンタしきい値の監視を編集するには、次の手順に従います。

パフォーマンス カウンタのしきい値の監視を編集するには

  1. Operations Manager 2007 のオペレータ コンソールで、[Authoring] をクリックします。

  2. [Authoring]、[Management Pack Objects]、[Monitors] の順に移動します。

  3. [SMS Server] を選択します。

  4. [SMS Server]、[Entity Health]、[MOM 2005 Computer Role Health] の順に移動し、サイト サーバーの [SS] のように、適切なコンピュータ役割を選択します。

  5. 編集するパフォーマンスしきい値監視ルールをダブルクリックします。[Performance Threshold Properties] ダイアログ ボックスが開きます。

  6. [Configuration] タブを選択します。

  7. [Edit...] をクリックします。[Xml Configuration] ダイアログ ボックスが開きます。

  8. XML テキストで、変更するしきい値を編集します。

    • 重大なエラーのしきい値を変更するには、<CriticalErrorExpression> に入れ子になった <ValueExpression> を指定します。

    • 警告のしきい値を変更するには、<WarningExpression> に入れ子になった <ValueExpression> を指定します。

  9. [OK] をクリックします。[OK] をクリックします。変更したしきい値がサーバーに配布されます。

関連項目

概念

管理パックのテストとパイロット テスト
サポートされている SMS 構成
管理パックの監視シナリオ

その他のリソース

SMS 2003 管理パックのトラブルシューティング
Microsoft System Management Server 2003 管理パックの参照資料


SMS 2003 管理パックの操作タスクの実行

重大、もしくはその可能性のあるアラートを識別するため、すぐにすべてのアラートを確認し、解決することをお勧めします。さらに、ご使用の環境に合わせて他のタスクも定期的に実行してください。重要な問題の多くはアラートの原因にはなりませんので、定期的な注意が必要です。Microsoft® Systems Management Server (SMS) 2003 管理パックには、データの時間的変化と、問題の示すパターンを表示するビューとレポートがあります。アラートが生成される前に問題を解決するため、ビューとレポートを確認してください。

このセクションにあるとおり、毎日、毎週、および毎月のタスクを実行してください。ご使用の環境のニーズに合わせてタスクの頻度は調整してください。

ここでは、次のことについて説明します

SMS 2003 の毎日のタスク

SMS 2003 の毎週のタスク

SMS 2003 の毎月のタスク

SMS 2003 管理コンソールのタスク

関連項目

概念

管理パックの監視シナリオ
SMS 2003 管理パックの展開

その他のリソース

Systems Management Server 2003 管理パックの概要
SMS 2003 管理パックの操作タスクの実行
SMS 2003 管理パックのトラブルシューティング
Microsoft System Management Server 2003 管理パックの参照資料


SMS 2003 の毎日のタスク

次のタスクは毎日実行することをお勧めします。

  • すべてのオープン アラートを確認する。

  • コンピュータ グループのメンバシップを確認する。

  • すべての Operations Manager 2007 エージェントが Operations Manager 2007 サーバーと通信していることを確認する。

  • パフォーマンス バックログを確認する。

  • パフォーマンスの処理率を確認する。

  • Operations Manager 2007 エージェントとサーバー パフォーマンスを確認する。

  • 通知先グループのメンバシップまたはイベント処理ルール通知先グループを確認する。

  • SMS 2003 サイト バックアップを確認する。

  • イベントを確認する (オプション)。

すべてのオープン アラートを確認する

SMS 2003 管理パックのアラートは、次のアラート記述形式で表示されます。

$Computer$ <Rule Name>

$Description$

Event details

Operations Manager 2007 内のすべてのアラートを確認して、それらをすぐに解決するようにします。次のいずれかの方法で、オープン アラートを確認できます。

  • Operations コンソールで、[監視] ボタンをクリックし、[Microsoft Systems Management Server (SMS) 2003] を展開して [アラート] をクリックします。

  • Operations コンソールで、[監視] ボタンをクリックし、[Microsoft Systems Management Server (SMS) 2003] を展開して [全般] をクリックします。[過去 72 時間の新規アラート] を選択します。

  • [コンピュータとグループ] をクリックすることで、アラートをコンピュータまたはコンピュータ グループ別に表示できます。アラートの重要度別に概要を表示するには、調べる SMS 2003 コンピュータ グループを右クリックし、[表示] をクリックし、[アラート] をクリックします。

  • [状態の表示] を使用してアラートを表示できます。[状態の表示] には、コンピュータと最も重要度の高いアラートの一覧が表示されます。任意のコンピュータをダブルクリックすると、現在のアラートの一覧を取得できます。

  • [ダイアグラムの表示] を使用してアラートを表示できます。SMS 2003 階層の [ダイアグラムの表示] では、SMS 2003 階層がグラフィカルに表示されます。コンピュータごとに、最も重要度の高いアラートを示す状態コメントがあります。任意のコンピュータをダブルクリックすると、現在のアラートの一覧を取得できます。

次の順序ですべての新規アラートを確認することをお勧めします。

  1. SMS 2003 コア サービスのアラート

  2. SMS 2003 依存サービスのアラート

  3. SMS 2003 サイト システムのステータス サマライザベースのアラート

  4. SMS 2003 管理ポイントの稼動状態のアラート

  5. SMS 2003 ステータス メッセージベースのアラート

  6. SMS 2003 コンポーネントのアラート

  7. SMS 2003 バックログのアラート

  8. SMS 2003 受信トレイの管理アラート

  9. SMS 2003 SMS サイト バックアップの失敗のアラート

  10. SMS 2003 プログラムの失敗のアラート

コンピュータ グループのメンバシップを確認する

コンピュータ グループのメンバシップは、Operations Manager 2007 を使用して確認できます。

  • Operations コンソールで、[Authoring] ボタンをクリックし、[グループ] をクリックして該当する SMS 2003 コンピュータ グループを右クリックします。表示された各コンピュータ グループに正しいコンピュータが含まれていることを確認します。

エージェントが Operations Manager 2007 サーバーと通信していることを確認する

エージェントと監視インフラストラクチャ間の通信に失敗すると、アラートを受信できなくなります。可用性レポートを実行して、エージェントと Operations Manager 2007 を実行しているサーバーが通信していることを確認します。詳細については、Operations Manager 2007 ヘルプの Operations Manager 2007 での可用性レポートの作成方法に関するトピックを参照してください。

パフォーマンス バックログとパフォーマンス処理率を確認する

パフォーマンス バックログとパフォーマンス処理率は、毎日の傾向を検出し、SMS 階層内で何が起こっているのかを理解するうえで非常に役に立ちます。パフォーマンス バックログとパフォーマンス処理率は、Operations Manager 2007 で表示できます。

パフォーマンス バックログを確認するには

パフォーマンス バックログを確認するには、次の手順を実行します。

パフォーマンス バックログを確認するには

  1. Operations コンソールで、[監視] ボタンをクリックし、[Microsoft Systems Management Server (SMS) 2003] を展開します。

  2. [Performance]、[Backlogs] の順に展開します。次に、該当するコンポーネント サブフォルダをクリックします。カウンタ オプションを使用すると、表示されるデータやコンピュータ数を減らしたり、対象のコンピュータだけを選択したりできます。

パフォーマンスの処理率を確認するには

パフォーマンスの処理率を確認するには、次の手順を実行します。

パフォーマンスの処理率を確認するには

  1. Operations コンソールで、[監視] ボタンをクリックし、[Microsoft Systems Management Server (SMS) 2003] を展開します。

  2. [Performance]、[Backlogs] の順に展開します。次に、該当するコンポーネント サブフォルダをクリックします。カウンタ オプションを使用すると、表示されるデータやコンピュータ数を減らしたり、対象のコンピュータだけを選択したりできます。

SMS 2003 サイト バックログの監視

エンタープライズ環境での必要に応じて、SMS サイト バックアップ保守タスクを有効にし、バックアップをスケジュールしてください。SMS サイト バックアップ サービスが起動すると、まず SMS_EXECUTIVE、SMS_SQL_MONITOR、および SMS_SITE_COMPONENT_MANAGER を含むすべての SMS サービスが停止します。SMS サイト バックアップ プロセスは、次のことを実行しているときはランタイム バックアップをサポートしません。

  • SMS インストール フォルダの一部のバックアップ エクスポート パスへのコピー

  • 各種 SMS レジストリ値のバックアップ

  • Microsoft SQL Server™ を実行しているサーバー内の SMS サイト データベースのバックアップ

バックアップが完了すると、SMS サイト バックアップ サービスは SMS サービスを再開します。バックアップ プロセス中のこれらのサービスの停止と開始は正常動作であり、重大なエラーを示しているわけではありません。SMS サイト バックアップの最中は、これらのサービスの停止により発生が予想されるアラートは抑制されます。SMS サイト バックアップの停止と開始と同様に、これらのサービスの停止と開始も相関させることができますそれを行うには、次のルールを有効にする必要があります。これらのルールは、SMS サイト バックアップ サービスが開始または停止されたときに情報アラートを生成します。

  • SMS 2003 サービスの実行停止 : SMS_SITE_BACKUP

  • SMS 2003 サービスの実行開始 : SMS_SITE_BACKUP

次のアラートは、SMS サイト バックアップ サービスを開始できなかったとき、または SMS バックアップ サービスが予期せずに停止したときに生成されます。

  • SMS 2003 サービスの失敗 : SMS_SITE_BACKUP は予期せず終了しました

  • SMS 2003 サービスの失敗 : SMS_SITE_BACKUP は起動時に停止しました

  • SMS 2003 サービスの失敗 : SMS_SITE_BACKUP は開始できませんでした

  • SMS 2003 サービスの失敗 : SMS_SITE_BACKUP はログオンできませんでした

  • SMS 2003 サービスの失敗 : SMS_SITE_BACKUP は別のサービスに依存しており、それを開始できなかったか、または存在していません。

サービスの予期せぬ終了を示すアラートが表示されている場合は、停止されたサービスがすべて再開していることを確認します。それらのサービスを再開する前に SMS サイト バックアップ サービスが終了している場合があります。

次のステータス メッセージ アラートは、バックアップ プロセスの成功または失敗を示すために生成されます。

  • SMS 2003 ステータス : サイト バックアップは正常に完了しました

  • SMS 2003 ステータス : サイト バックアップに失敗しました

バックアップは、アクセスの問題、ディスク領域不足、特定のサービスの開始または停止の失敗、または SQL Server 操作の失敗が原因で失敗することがあります。

イベントを確認する

イベントは重大ではない障害を示しており、Operations Manager 2007 エージェントがどのように機能しているかについての情報を提供するため、定期的に確認する必要があります。

イベントを確認するには

イベントを確認するには、次の手順を実行します。

イベントを確認するには

  1. Operations コンソールで、[監視] ボタンをクリックします。

  2. [Microsoft Systems Management Server (SMS) 2003] を展開し、[イベント] をクリックします。

関連項目

概念

SMS 2003 の毎週のタスク
SMS 2003 の毎月のタスク
SMS 2003 管理コンソールのタスク

その他のリソース

SMS 2003 管理パックの操作タスクの実行
SMS 2003 管理パックのトラブルシューティング
Microsoft System Management Server 2003 管理パックの参照資料


SMS 2003 の毎週のタスク

毎日実行するタスク以外に、次のタスクは毎週実行する必要があります。

  • レポートを確認する。SMS 2003 管理パックに含まれるレポートの一覧については、このガイドの「SMS 2003 のレポート」を参照してください。

  • 潜在的な問題と傾向について、過去数週間のアラート、イベント、およびパフォーマンスを確認する。

  • 必要な場合は、Operations Manager 2007 エージェント ハートビート間隔、サービス監視ステータス チェック間隔、エージェント マネージャ ハートビート スキャン間隔、検出間隔、データベース クリーンアップ パラメータなどの Operations Manager 2007 構成設定値を調整する。

  • SMS サイトのバックアップ履歴を確認する。

  • SMS 2003 の Operations Manager 2007 構成グループのバックアップ履歴を確認する。

  • SQL Server データベースおよびログを確認する。

  • SMS 2003 可用性レポートを実行して、SMS サーバーおよびそれらのコンポーネントの可用性を取得する。

  • SMS 2003 階層ダイアグラムを使用して SMS 階層を確認する。

関連項目

概念

SMS 2003 の毎日のタスク
SMS 2003 の毎月のタスク
SMS 2003 管理コンソールのタスク

その他のリソース

SMS 2003 管理パックの操作タスクの実行
SMS 2003 管理パックのトラブルシューティング
Microsoft System Management Server 2003 管理パックの参照資料


SMS 2003 の毎月のタスク

毎日および毎週実行するタスクに加えて、次のカテゴリのデータは毎月確認する必要があります。

最も一般的なアラートとイベント

  • 最も一般的なアラート

  • 最も一般的なイベント

  • ルール グループ別の最も一般的なアラートとイベント

  • SMS 2003 コンポーネント別の最も一般的なアラートとイベント

  • SMS 2003 機能別の最も一般的なアラートとイベント

アクション計画を展開し、これらの数を減らします。

SMS バックログの監視

  • さまざまなサイト システムのバックログの傾向に関するレポートを調べます。

SMS バックログの傾向

  • バックログの数または SMS サイト システムのサービス レベル アグリーメント (SLA) に影響するバックログの許容できないレベルが、長期にわたり上昇傾向にならないように、バックログ関連のレポートを確認します。

SMS パフォーマンスの傾向 : 総数と処理率

  • データ探索レコード

  • ハードウェア インベントリ

  • ソフトウェア インベントリ

  • ソフトウェア メータリング

  • ステータス メッセージ

全般的なシステム パフォーマンス

  • ディスク使用量

  • メモリ使用量

  • プロセッサ使用量

SMS サービスの可用性

  • SMS_EXECUTIVE

  • SMS Agent Host サービス

  • SMS クライアント サービス

  • SMS_REPORTING_POINT

  • SMS_SERVER_LOCATOR_POINT

  • SMS_SQL_MONITOR

  • SMS_SITE_COMPONENT_MANAGER

SMS の可用性

  • SMS 2003 可用性レポートを実行して、SMS サーバーおよび SMS コンポーネントの可用性を確認します。

関連項目

概念

SMS 2003 の毎日のタスク
SMS 2003 の毎週のタスク
SMS 2003 管理コンソールのタスク

その他のリソース

SMS 2003 管理パックの操作タスクの実行
SMS 2003 管理パックのトラブルシューティング
Microsoft System Management Server 2003 管理パックの参照資料


SMS 2003 管理コンソールのタスク

SMS 管理コンソールのタスクを使用するには、Microsoft Systems Management Server (SMS) 2003 SP2 以降の管理コンソールを、Operations Manager 2007 の操作コンソールと同じコンピュータにインストールする必要があります。SMS 管理コンソールのインストール後、タスク機能を有効にするには、一度ログオフし、再度 Windows にログオンしてください。

管理パックのタスク

タスク | 説明
SMS 管理コンソール | 選択しているコンピュータ用の SMS 管理コンソールを開きます。SMS サイト サーバー役割をホストしているコンピュータに適用されます。
すべての SMS ステータス メッセージ | コンピュータのサイト サーバーの入力を求めるプロンプトが表示され、MMC ウィンドウが開きます。次いで、ステータス メッセージ クエリを実行して、選択しているコンピュータに関連したステータス メッセージを返します。すべてのシステムに適用されます。
SMS サービス マネージャ | 選択しているコンピュータ用の SMS サービス マネージャを開きます。SMS サイト サーバー役割をホストしているコンピュータに適用されます。
SMS リソース エクスプローラ | コンピュータのサイト サーバーの入力を求めるプロンプトが表示され、MMC ウィンドウが開いて、SMS リソース エクスプローラに選択しているコンピュータのデータを表示します。すべてのシステムに適用されます。

関連項目

概念

SMS 2003 の毎日のタスク
SMS 2003 の毎週のタスク
SMS 2003 の毎月のタスク

その他のリソース

SMS 2003 管理パックの操作タスクの実行
SMS 2003 管理パックのトラブルシューティング
Microsoft System Management Server 2003 管理パックの参照資料


SMS 2003 管理パックのトラブルシューティング

製品の問題の原因を突き止めるために、さまざまな手順が用意されています。

  • Operations Manager 2007 が適切にインストールされていることを確認します。

  • Operations Manager 2007 の構成が、正しく設定されていることを確認します。

  • すべての Microsoft® Systems Management Server (SMS) システムが、操作管理情報で構成されていることを確認します。

  • 管理された SMS プロバイダおよび SMS サイト データベース コンピュータすべてに Operations Manager 2007 エージェントがインストールされ、他のコンピュータに対するプロキシ化が有効になっていることを確認します。

  • 管理パックのインポートが正常に完了していることを確認します。

  • ルールや関連付けられたアラートなど、すべての関連するエンティティが有効になっていることを確認します。

  • コンピュータ グループに、適切なコンピュータのみが含まれていることを確認します。この確認は、ビューで行えます。

  • ハートビート エラー アラートが発生していないことを確認します。

  • ハートビート間隔が適切に設定され、ルールが Operations Manager 2007 エージェント コンピュータに継承されていることを確認します。

  • 依存サービス (Windows Management Instrumentation (WMI)、World Wide Web 発行サービス、インターネット インフォメーション サービス (IIS) 管理サービス、バックグラウンド インテリジェント転送サービス (BITS)、および MSSQLServer を含む) が、SMS 2003 サイト システムにインストールされ、適切に実行されていることを確認します。

  • アラートの過剰な発生、不正な構文、スクリプトの実行時間が長すぎるなどの理由で、ルールが Operations Manager 2007 により自動的に無効にされていないことを確認します。

  • すべてのパフォーマンス カウンタが適切にインストールされていることを確認します。

ここでは、次のことについて説明します

SMS 2003 の既知の問題

関連項目

概念

管理パックの監視シナリオ
SMS 2003 管理パックの展開

その他のリソース

Systems Management Server 2003 管理パックの概要
SMS 2003 管理パックの操作タスクの実行
Microsoft System Management Server 2003 管理パックの参照資料


SMS 2003 の既知の問題

Systems Management Server 2003 用 Operations Manager 2007 管理パックでは、次のような問題が確認されています。

保守モードとトポロジ ビューは SMS 2003 SP3 を必要とする

SMS は、WMI サービスを停止させる Microsoft 以外のソフトウェアのインストールを妨げる場合がある

WMI の監視

SMS タスクが SMS 2003 管理コンソールのインストールで使用されたユーザー コンテキストでしか動作しない

SMS 2003 管理パックは、SMS 管理コンソールがインストールされている SMS セカンダリ サイトを検出できない

システムの再起動

SMS 2003 Monitor SMS Status Messages スクリプト

SMS 2003 Monitor Site Summarizer スクリプトの実行間隔がサイト システムのステータス サマライザの既定のポーリング間隔より遅延される

センダの接続を監視するステータス メッセージ ルールがセンダの機能に依存している

既定で無効になっている BITS 監視

アプリケーション プロバイダ パスの既定の設定 C:\SMS\Logs は、一部の SMS サイト サーバーで無効である可能性がある

保守モードとトポロジ ビューは SMS 2003 SP3 を必要とする

Operations Manager 2007 では、SMS s003 サイト サーバーに SMS 2003 SP3 がインストールされていなければ、保守モードを有効にしたり、サイト トポロジを表示したりすることができません。詳細については、「サポートされている SMS 構成」を参照してください。

SMS は、WMI サービスを停止させる Microsoft 以外のソフトウェアのインストールを妨げる場合がある

SMS 2003 管理パックは、WMI サービスにアクセスする Microsoft 以外のソフトウェアのインストールを妨げることがあります。管理パックのスクリプトの大半は、WMI を使用してレジストリにアクセスし、また WMI サービスを再起動することができます。WMI サービスが有効で起動可能な状態にあれば、コンポーネント オブジェクト モデル (COM) は WMI を再起動します。

Microsoft 以外のソフトウェアのインストール時またはアップグレード時に、WMI を無効にせずに WMI を停止させると、WMI スクリプトの自動再起動によってそのソフトウェアの正常なインストールが妨げられる場合があります。そのため、WMI または WMI プロバイダのアップグレードで、インストール プログラムがまず WMI サービスを無効にしない場合は、問題が発生する可能性があります。この問題は、WMI のすべてのクライアントに当てはまります。

WMI の監視

  • 次のルールは、予期しないサービスの失敗に関する Windows NT® システム イベント ログのイベントに基づいています。このイベント ログは、サービス コントロール マネージャによって書き込まれます。これらのルールに関連する既知のオペレーティング システムの制限はありません。

  • SMS 2003依存サービスの失敗 : Windows Management Instrumentation は予期せずに終了しました。

  • SMS 2003依存サービスの失敗 : Windows Management Instrumentation は起動時に停止しました。

  • SMS 2003依存サービスの失敗 : Windows Management Instrumentation を起動できませんでした。

  • SMS 2003依存サービスの失敗 : Windows Management Instrumentation はログオンできませんでした。

  • SMS 2003依存サービスの失敗 : Windows Management Instrumentation は別のサービスに依存しており、それを開始できなかったか、または存在していません。

SMS タスクが SMS 2003 管理コンソールのインストールで使用されたユーザー コンテキストでしか動作しない

この問題が発生するのは、SMS 管理コンソールのインストール時に SMS_UI_PATH 環境変数がシステム環境変数ではなく、ユーザー環境変数として作成されているためです。この問題を回避するには、SMS_UI_PATH の名前と値をコピーし、この変数をシステム環境変数として定義します。これにより、エラーを発生させることなく、すべてのオペレータと管理者がタスクを呼び出せるようになります。

Systems Management Server 2003 管理パックは、SMS 管理コンソールがインストールされている SMS セカンダリ サイトを検出できない

SMS セカンダリ サイト サーバーであるコンピュータに Systems Management Server 2003 管理コンソールをインストールすると、SMS 2003 管理パックはそのサーバーを SMS セカンダリ サイト サーバーとして識別できなくなります。

この問題を回避するには、SMS セカンダリ サイト サーバーに SMS 管理コンソールをインストールするときに、レジストリ値 HKLM\SOFTWARE\Microsoft\SMS\Setup\Type を 4 から 2 に変更する必要があります。

システムの再起動

システムの再起動時にも、サービス停止アラートは、数個しか生成されない場合があります。システムが再起動したことを通知するイベントやアラートはありません。予期される、または予期しないシステム シャットダウンを検出する最適な方法は、Microsoft Windows Server Base Operating System 管理パックをインストールすることです。このパックには、システムの再起動をアラートで通知するルールが含まれています。システムの再起動が発生したかどうかを判断する別の方法は、SMS ログ、Operations Manager 2007 NT イベント ログ、Windows NT イベント ログ、およびエージェント通信に関する Operations Manager 2007 イベントを確認する方法です。

SMS 2003 Monitor SMS Status Messages スクリプト

SMS ステータス メッセージ テーブルに含まれるメッセージの数が 4,294,967,296 を超えると、レコード ID は再びゼロからカウントされます。SMS 2003 Monitor SMS Status Messages スクリプトには、レコード ID がいつゼロにリセットされたのかを検出するメカニズムがありません。現時点で、このスクリプトが監視するのは、最後に処理されたステータス メッセージのレコード ID 以降の ID を持つメッセージのみです。そのため、レコード ID がリセットされると、管理パックは新しいステータス メッセージを検出できなくなります。

サイト サーバーで、HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER レジストリ キーの Next Status Message Record ID レジストリ値を確認します。これは、SQL StatusMessages テーブルに格納されている次のレコード ID です。この値が LastRecordID の値より小さい場合は、StatusMessages テーブルが一巡してリセットされていることを示します。スクリプトは、Next Status Message Record ID のレジストリ値が VarSet ファイルの LastRecordID の値より大きくなるまで、メッセージの処理を再開しません。

サイト サーバーで HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\COMPONENTS\SMS_STATUS_MANAGER レジストリ キーを定期的に監視し、次のステータス メッセージのレコード ID を確認してください。SMS 階層の下位に位置する小規模な組織やサイトでは、2 ～ 3 か月ごとにこのレジストリ キーを確認する必要があります。複数の子サイトを持つ大規模な組織やサイトでは、このレジストリ キーを毎月確認してください。この値が 4,294,967,296 に近づいている場合は、さらに頻繁に確認を行ってください。レコード ID がゼロにリセットされたら、サイトの SMS サイト データベース サーバーを実行しているコンピュータで、ステータス メッセージの監視をブロック解除する必要があります。SMS サイト データベースの場所は、SMS のインストール時に指定します。

レジストリ キーの監視を自動化する 1 つの方法は、コンピュータ属性とコンピュータ グループを作成して、このしきい値に近づきつつあるコンピュータを監視する方法です。

構成グループ内のすべての SMS サイト データベースを検索するには

  1. オペレーション コンソールで、[Authoring] をクリックします。

  2. 結果ペインで、[Microsoft Systems Management Server (SMS) 2003] を右クリックし、[View Group Members] を選択します。

ステータス メッセージの監視をブロック解除するには

  1. SMS サイト データベースの役割をホストしているコンピュータで、Windows の [Temp] フォルダ内のテキスト ファイル SMS 2003 Monitor SMS Status Messages.VarSet を開きます。LastRecordID_[SMSDatabaseName] エントリは、SQL StatusMessages テーブルに格納されている、スクリプトが処理した最後のステータス メッセージのレコード ID です。

  2. SMS サイト データベースの役割をホストしているコンピュータの SMS 2003 Monitor SMS Status Messages.VarSet ファイルで、適切なサイトの LastRecordID_[SMSDatabaseName] の値を、Next Status Message Record ID レジストリ値から 1 を引いた値に変更します。結果が 4,294,967,296 になる場合は、値をゼロに設定して、ファイルを保存します。

SMS 2003 Monitor Site Summarizer スクリプトの実行間隔がサイト システムのステータス サマライザの既定のポーリング間隔より遅延される

SMS 2003 Monitor Site System Summarizer スクリプトの実行間隔は、毎正時に実行されるサイト システムのステータス サマライザのポーリング間隔より 10 分遅延されます。SMS 管理コンソールでは、サイト システムのステータス サマライザのスケジュールを構成することが可能です。ただし、変更できるのは他の保守タスクの実行間隔のみであり、ステータス サマライザ自身のポーリング間隔は変更できません。SMS 2003 Monitor Site System Summarizer スクリプトは、[SMS 2003 スケジュール間隔 : 60 分に 1 回、同期 : 00:10] 時間指定イベント プロバイダによって実行されます。この 10 分の遅延の間に、サイト システムのステータス サマライザはサイクルを完了することができます。10 分でサイクルが完了しない場合は、遅延時間を大きくする必要があります。遅延時間を大きくしないと、サイト システムのサマライザがサイクルを完了する前に、スクリプトが実行されます。その場合は、古いサイト システム ステータスがレポートされるおそれがあります。

センダの接続を監視するステータス メッセージ ルールがセンダの機能に依存している

センダが親サイトに接続できないときは、ステータス メッセージも SMS の上位階層に転送できないため、管理パックはそれらのステータス メッセージに基づくアラートを生成することができません。これは、SMS 2003 Monitor Status Message スクリプトが実行されていないセカンダリ サイトの場合に、特に重大な問題となります。センダの接続を監視する次のステータス メッセージ ルールは、センダの機能に依存しているため、既定で無効になっています。

  • SMS 2003 ステータス : センダは、LAN 経由でリモート サイトに接続できません (標準セキュリティ)。

  • SMS 2003 ステータス : センダは、RAS 接続経由でリモート サイトに接続できません。

  • SMS 2003 ステータス : センダは、LAN 経由でリモート サイトに接続できません (上級セキュリティ)。

メモ
これらのルールはすべて、既定で無効になっています。これらのルールが機能するには、各 SMS サイト データベース サーバー、または最低限としてセントラル サイトが、管理されたコンピュータでなければなりません。

その代わり、アプリケーション ログ プロバイダ SMS 2003 センダ ログに基づいて監視を行う、類似した機能を持つルールが用意されています。これらのルールは、既定で有効になっています。これらのルールを無効にする場合は、対応する上記のステータス メッセージ ルールを有効にすることを検討してください。ただし、両方のルール セットを有効にすることは、アラートの重複生成につながるため、避ける必要があります。これらのイベントまたはアラート ルールを 1 つに統合して、アクティブなステータス メッセージ ルールおよびコンポーネント ルールの両方を処理することはできません。

  • SMS 2003 コンポーネント : センダは、LAN 経由でリモート サイトに接続できません (標準セキュリティ)。

  • SMS 2003 コンポーネント : センダは、RAS 接続経由でリモート サイトに接続できません。

  • SMS 2003 コンポーネント : センダは、LAN 経由でリモート サイトに接続できません (上級セキュリティ)。

これらのルールが機能するには、SMS ログ ファイルをポイントするよう、ルールを修正する必要があります。加えて、センダを持つ各 SMS サーバーは、管理されたコンピュータでなければなりません。

既定で無効になっている BITS 監視

バックグラウンド インテリジェント転送サービス (BITS) サービスは、SMS アドバンスト クライアントの要求に応じて開始されるため、SMS 2003 管理パックでは、次のルールが既定で無効になっています。

  • SMS 2003 依存サービスの実行 : バックグラウンド インテリジェント転送サービス

自動的に開始されるよう構成されたサービスがある場合は、このルールを有効にする必要があります。

次のルールは、既定で有効になっています。これは、BITS サービスに関連する問題を監視するため、および SMS Agent Host が BITS サービスを開始する必要があるのにできない場合にそれをレポートするためです。

  • SMS 2003 サービスの失敗 : バックグラウンド インテリジェント転送サービスが予期せず終了しました。

  • SMS 2003 サービスの失敗 : バックグラウンド インテリジェント転送サービスが開始時にハングしました。

  • SMS 2003 サービスの失敗 : バックグラウンド インテリジェント転送サービスを開始できませんでした。

  • SMS 2003 サービスの失敗 : バックグラウンド インテリジェント転送サービスはログオンできませんでした。

SMS 2003 サービスの失敗 : バックグラウンド インテリジェント転送サービスは別のサービスに依存しており、それを開始できなかったか、または存在していません。

アプリケーション プロバイダ パスの既定の設定 C:\SMS\Logs は、一部の SMS サイト サーバーで無効である可能性がある

アプリケーション ログ プロバイダを使用して C:\SMS\Logs の SMS ログ ファイルを監視する 4 つのコンポーネント ルールがあります。

  • SMS 2003 コンポーネント : センダは、LAN 経由でリモート サイトに接続できません (標準セキュリティ)。

  • SMS 2003 コンポーネント : センダは、RAS 接続経由でリモート サイトに接続できません。

  • SMS 2003 コンポーネント : センダは、LAN 経由でリモート サイトに接続できません (上級セキュリティ)。

  • SMS 2003 コンポーネント : 配布マネージャはパッケージを処理できませんでした。

センダ ルールは既定で有効になっていますが、配布マネージャ ルールは既定で無効になっています。SMS を C ドライブ以外のドライブにインストールした場合や、ログが格納される既定のフォルダを変更した場合は、このルールを修正してから有効にする必要があります。適切なフォルダでログ ファイルを検索するようこのルールを修正しなければ、アラートは必要な情報を返しません。

正しいパスを指すようルールを修正するときは、ログ ファイルへのパスを入力するか、環境変数を作成してその変数を使用するようルールを修正することができます。パスを入力する場合は、このルールの影響を受けるすべてのサイト サーバーで有効なパスを指定しなければなりません。プライマリ サイト サーバー用とセカンダリ サイト サーバー用に 2 つのパスがある場合は、次の手順を実行してください。

ログ ファイルの代替パスを使用するようにコンポーネント ルールの XML を修正するには

  1. [Operations Manager 2007 Operations Console] で、[Authoring] をクリックし、[Management Pack Objects] を展開して、[Rules] をクリックします。

  2. [詳細] ペインで、修正するルールを右クリックして、[プロパティ] を選択します。

  3. [Configuration] タブをクリックします。

  4. [Responses] ペインで、XML を編集する応答を選択します。

  5. [Edit...] をクリックします。[GenerateAlert - Properties] ダイアログ ボックスが開きます。

  6. [GenerateAlert - Properties] ダイアログ ボックスの [Configuration] タブで、[Edit…] をクリックします。

  7. ディレクトリ文字列を適切に編集します。[OK] をクリックし、[Apply] をクリックします。次に [OK] をクリックして、変更を保存します。

関連項目

概念

サポートされている SMS 構成

その他のリソース

SMS 2003 管理パックのトラブルシューティング
Systems Management Server 2003 管理パックの概要
Microsoft System Management Server 2003 管理パックの参照資料


Microsoft System Management Server 2003 管理パックの参照資料

これらの参照資料には、Operations Manager 2007 および System Management Server 2003 についてのガイダンスが掲載されています。

ここでは、次のことについて説明します

Microsoft System Management Server 2003 管理パックのその他の参考資料

SMS 2003 管理パックのサイトおよびコンポーネント

SMS 2003 のコンピュータ グループ

SMS 2003 のルール グループ

SMS 2003 のプロバイダ

SMS 2003 のスクリプト

Microsoft SMS 2003 のビュー

SMS 2003 のダイアグラム

SMS 2003 のレポート

関連項目

概念

管理パックの監視シナリオ
SMS 2003 管理パックの展開

その他のリソース

Systems Management Server 2003 管理パックの概要
SMS 2003 管理パックの操作タスクの実行
SMS 2003 管理パックのトラブルシューティング


Microsoft System Management Server 2003 管理パックのその他の参考資料

Microsoft System Management Server 2003 管理パックに関しては、次の参考資料が入手できます。

Microsoft Operations Manager 2007

インターネット上で提供されている Operations Manager 2007 の主な製品ドキュメントにアクセスし、System Center Operations Manager 2007 の最新情報を入手するには、Operations Manager 2007 製品 Web ページ (http://go.microsoft.com/fwlink/?LinkID=83259) (英語の可能性あり) を参照してください。

SMS 2003

SMS 2003 を展開および使用するために必要なすべての情報が、主な製品ドキュメント、SMS 管理コンソールのヘルプ、 SMS 用語集、および SMS オンライン ライブラリで提供されています。SMS オンライン ライブラリと SMS 管理コンソールのヘルプには、SMS 管理コンソールからアクセスできます。

SMS 2003 オンライン ライブラリ

SMS オンライン ライブラリでは、SMS を展開および使用するために必要なすべての情報にアクセスすることができます。SMS 2003 のインストール後、SMS オンライン ライブラリを実行する方法は 2 つあります。

  • [スタート] ボタンをクリックし、[プログラム] をクリックします。次に、[Systems Management Server] をクリックして、[SMS オンライン ライブラリ] を選択します。

  • SMS 管理コンソール ツリーで [SMS オンライン ライブラリ] を右クリックし、[オンライン ライブラリの実行] をクリックします。

オンライン ライブラリには、次のものが含まれています。

  • SMS に関する重要な情報が記載されている "SMS 2003 リリース ノート"。

  • SMS 2003 の現バージョンと前バージョンとの相違点が説明されている "What's New in this Version of SMS"。

  • SMS 製品ドキュメントの Web ページへのリンク。

  • SMS 2003 Device Management Feature Pack と SMS 2003 Operating System Deployment Feature Pack のダウンロード ページへのリンク。

Web 上の SMS

  • 関連製品の技術資料や情報を検索するには、Microsoft Systems Management Server 2003 の製品 Web サイト (英語の可能性あり) を参照してください。SMS の Web サイトでは、Microsoft Windows® XP や Microsoft Office XP などの他の Microsoft 製品と共に SMS を使用する方法についても、具体的な情報が提供されています。

  • 参照およびダウンロードできる SMS 2003 の主な製品ドキュメントへのリンクは、Systems Management Server 2003 製品ドキュメントの Web ページ (英語の可能性あり) を参照してください。

  • Microsoft は、無料のニュースグループを多数運営しています。ニュースグループに質問を投稿すると、他のユーザーから、また多くの場合 SMS 製品チームのメンバからも、無料でサポートを受けることができます。無料のニュースグループの詳細については、Systems Management Server コミュニティの Web ページ (英語の可能性あり) を参照してください。

  • How-To 技術情報記事、FAQ、Web キャスト、ニュースグループなどについては、Systems Management Server 製品サポートの Web ページを参照してください。

  • SMS の質問に対する正確な回答を迅速に得るため、Microsoft サポート技術情報およびその他の技術資料を検索するには、Microsoft サポート技術情報の Web サイトにアクセスしてください。問題に割り当てられている番号 "Qxxxxxx" または "xxxxxx" を使用して、サポート技術情報を照会し、特定の問題に関する記事を検索することができます。

フィードバックの提出

  • SMS ドキュメント チームは、皆様から寄せられるフィードバックやご意見を参考にして、必要とされる製品情報を提供しています。SMS ドキュメントに関するフィードバックは、SMS Documentation までお送りください。

関連項目

概念

SMS 2003 のコンピュータ グループ
SMS 2003 のプロバイダ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー


SMS 2003 管理パックのサイトおよびコンポーネント

SMS 2003 コンポーネントには、SMS セントラル サイト サーバー、SMS サイト データベース、および SMS 管理コンソールが含まれます。通常、SMS セントラル サイト サーバー、SMS サイト データベース、および SMS 管理コンソールは同じサーバーに置かれ、各サイト システムの役割は専用のサーバーに置かれます。セントラル サイト サーバーとデータベースは、任意のサイト システムの役割と共に、単一の SMS サイトを構成します。単一 SMS サイトに、複数の重複したサイト システムの役割が含まれる場合もあります。たとえば、単一サイトに複数のクライアント アクセス ポイント (CAP) が含まれることがあります。また、SMS 2003 サイトは階層化できます。単一 SMS サイトに、サーバー ロケータ ポイントなど、一部のサイト サーバーの役割が含まれない場合もあります。

SMS 2003 管理パックは、SMS サーバー コンポーネントを監視する目的で設計されています。この管理パックは、SMS クライアント コンピュータの機能を監視する目的では設計されていません。ただし、Operations Manager 2007 を使用すれば、SMS クライアント コンピュータ上のアプリケーションを監視することができます。

SMS 2003 コンポーネントについての詳細は、SMS 2003 オンライン ライブラリを参照してください。SMS 2003 のドキュメントへのリンクは、このガイドの「Microsoft System Management Server 2003 管理パックのその他の参考資料」を参照してください。

主なサーバーの役割とコンポーネントには次のものが含まれます。

  • クライアント アクセス ポイント

  • 配布ポイント

  • 管理ポイント

  • サーバー ロケータ ポイント

  • レポート ポイント

  • サイト サーバー

  • サイト データベース

  • センダ

  • アドバンスト クライアント

  • レガシ クライアント

  • SMS プロバイダ

  • SMS 管理コンソール

クライアント アクセス ポイント

CAP の役割は、レガシ クライアントと SMS サイト サーバー間の接続点です。CAP は、すべてのレガシ クライアント データをサイト サーバーに渡します。レガシ クライアント コンピュータは、CAP に接続して、SMS サイト サーバーから管理情報を取得します。CAP は 1 つの SMS サイトに対してのみ機能します。既定では、CAP はサイト サーバーにインストールされます。CAP は次の処理も行います。

  • クライアント インストール中や、その後に変更を加える際に、レガシ クライアントに特定の構成指示とファイルを提供します。

  • レガシ クライアント コンピュータがアドバタイズを確認する場所として機能します。

  • レガシ クライアントからデータを受信し、SMS サイト サーバーに転送します。たとえば、クライアントは、ハードウェアまたはソフトウェア インベントリを完了して、インベントリ データ ファイルを作成すると、そのデータを CAP に送信します。クライアントから送信されるステータス メッセージはすべて CAP にレプリケートされます。

配布ポイント

配布ポイントは、SMS パッケージ ソース ファイルを格納します。このソース ファイルは、SMS によって配布されたソフトウェア プログラムをインストールする際に SMS クライアントが使用します。SMS 管理者がプログラムをアドバタイズすると、クライアントは、レガシ クライアントの CAP、またはアドバンスト クライアントの管理ポイントを通して、アドバタイズとプログラム情報を使用することができます。

SMS がセットアップされると、配布ポイントの役割がサイト サーバーに自動的に割り当てられます。SMS 管理者は、配布ポイントによるバックグラウンド インテリジェント転送サービス (BITS) を有効にすることができます。これにより、増分のパッケージ ファイルをアドバンスト クライアントにダウンロードできます。

アドバンスト クライアントは、BITS を使用して、クライアント ネットワークの接続容量を自動的に検出し、転送速度を効率的に調整します。この機能は、Microsoft Windows 2000、Microsoft Windows XP Professional、および Microsoft Windows Server™ 2003 オペレーティング システムを実行するクライアントでのみサポートされています。

管理ポイント

管理ポイントは、アドバンスト クライアントと SMS サイト サーバーとの第 1 の接続点です。SMS サイトの既定の管理ポイントは 1 つだけですが、Windows ネットワーク負荷分散サービスを使用すれば、複数の管理ポイントを構成することもできます。CAP とレガシ クライアント間の場合とほぼ同様、管理ポイントは次の処理を行います。

  • クライアント インストール後、特定のクライアント構成の詳細 (アドバンスト クライアント ポリシーとも呼ばれます) をアドバンスト クライアントに提供します。

  • アドバンスト クライアント コンピュータがアドバタイズを確認する場所として機能します。

  • アドバンスト クライアントの配布ポイントを検索します。

  • アドバンスト クライアントからインベントリ、ソフトウェア メータリング、およびステータス情報を受信し、SMS サイト サーバーに転送します。

サーバー ロケータ ポイント

サーバー ロケータ ポイントは、レガシ クライアントの CAP とアドバンスト クライアントの管理ポイントを検索します。サーバー ロケータ ポイントは、主にクライアント インストールで使用されます。サーバー ロケータ ポイントは次の処理を行います。

  • 自動 SMS サイト割り当てを行うようアドバンスト クライアントが構成されている場合、アドバンスト クライアントの管理ポイントを検索します。

  • クライアント インストールをログオン スクリプトで開始した場合や、インストール中に資格情報が不十分な場合に、アドバンスト クライアントに管理ポイントの場所を提供します。

  • レガシ クライアントに SMS サイト割り当てを提供し、ログオン スクリプトで開始したクライアント インストールの間 CAP を検索します。

レポート ポイント

レポート ポイントとは、インターネット インフォメーション サービス (IIS) を実行するサーバーのことです。このサービスは、レポート ビューアのコードや他の補足レポートをホストします。レポート ポイントは、自身の SMS サイト データベース サーバーとのみ通信します。

アドバンスト クライアント

SMS 2003 は、アドバンスト クライアントによって、モバイル コンピューティングのニーズに応えます。アドバンスト クライアントは、ソフトウェア配布、資産管理、およびリモート トラブルシューティングを含む、完全な SMS 機能セットをサポートします。また、モバイル ユーザーとデスクトップ ユーザーを区別することなく管理できます。アドバンスト クライアントは、BITS と呼ばれる Windows テクノロジを使用して、すべての管理操作に対して接続を提供します。

レガシ クライアント

アドバンスト クライアントをサポートするための要件を満たしていないコンピュータが組織にある場合は、レガシ クライアントを使用して管理することができます。以下のレガシ クライアント インストール方法を有効にし、構成および制御することができます。

  • ログオン スクリプトで開始するクライアント インストール

  • クライアント プッシュ インストール

  • 手動クライアント インストール

SMS プロバイダ

SMS プロバイダは、SMS サイト データベースのデータ要求を処理します。SMS プロバイダの役割は、SMS サイト サーバーまたは SMS サイト データベースと同じコンピュータにインストールされます。SMS プロバイダと SMS サイト データベースの両方を、サイト サーバーにインストールすることをお勧めします。SMS プロバイダにより、サイトにインストールされた SMS 管理コンソールは、データへアクセスします。

SMS 管理コンソール

SMS 管理コンソールは、SMS を管理するための、グラフィカル ユーザー インターフェイスです。このインターフェイスは、SMS 製品ソフトウェアと共に提供される、Microsoft 管理コンソール (MMC) スナップインを使用します。SMS 管理コンソールは、プライマリ サイト サーバーをインストールする際に、既定でインストールされます。他のサーバーやワークステーションにインストールすることもできます。

関連項目

概念

Microsoft System Management Server 2003 管理パックのその他の参考資料
SMS 2003 のコンピュータ グループ
SMS 2003 のプロバイダ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー


SMS 2003 のコンピュータ グループ

SMS 2003 管理パックでは、次のコンピュータ グループが提供されます。

  • Microsoft SMS 2003 管理コンソール

  • Microsoft SMS 2003 アドバンスト クライアント

  • Microsoft SMS 2003 セントラル サイト サーバー

  • Microsoft SMS 2003 クライアント

  • Microsoft SMS 2003 クライアント アクセス ポイント サーバー

  • IIS に基づく Microsoft SMS 2003 コンポーネント サーバー

  • SMS Executive に基づく Microsoft SMS 2003 コンポーネント サーバー

  • Microsoft SMS 2003 配布ポイント サーバー

  • Microsoft SMS 2003 管理ポイント サーバー

  • Microsoft SMS 2003 プライマリ サイト サーバー

  • Microsoft SMS 2003 プロバイダ

  • Microsoft SMS 2003 レポート ポイント サーバー

  • Microsoft SMS 2003 セカンダリ サイト サーバー

  • Microsoft SMS 2003 センダ サーバー

  • Microsoft SMS 2003 サーバー ロケータ ポイント サーバー

  • Microsoft SMS 2003 サーバー

  • Microsoft SMS 2003 サイト サーバー

  • Microsoft SMS 2003 レガシ クライアント

関連項目

概念

Microsoft System Management Server 2003 管理パックのその他の参考資料
SMS 2003 のコンピュータ グループ
SMS 2003 のプロバイダ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー


SMS 2003 のルール グループ

ここでは、重大なイベントとアラートを生成する Systems Management Server (SMS) 2003 管理パック内のルール グループとイベント ルールの一覧を示します。ルール グループの下にあるすべてのルールを確認するには、Operations Manager 2007 Operations コンソールの [Authoring] を参照してください。

SMS クライアント - アドバンスト

[SMS クライアント - アドバンスト] ルール グループには、SMS アドバンスト クライアントに関連するエラーのルールが含まれています。

  • SMS 2003 サービスの実行 : SMS Agent Host

  • SMS 2003 依存サービスの実行 : バックグラウンド インテリジェント転送サービス

  • SMS 2003 依存サービスの実行 : Windows Management Instrumentation

SMS クライアント アクセス ポイント

[SMS クライアント アクセス ポイント] ルール グループには、SMS クライアント アクセス ポイントに関連するエラーのルールが含まれています。

  • SMS 2003 サービスの実行 : SMS_EXECUTIVE

SMS 管理ポイント

[SMS 管理ポイント] ルール グループには、SMS 管理ポイントに関連するエラーのルールが含まれています。

  • SMS 2003 サービスの実行 : SMS Agent Host

  • SMS 2003 サービスの実行 : SMS_EXECUTIVE

  • SMS 2003 依存サービスの実行 : World Wide Web 発行サービス

  • SMS 2003 依存サービスの実行 : IIS 管理サービス

  • SMS 2003 管理ポイントの状態 : 状態

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるMP DDR バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超える MP HINV バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超える MP SINV バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超える MP FileCollection バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超える MP Relay Mgr バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超える MP Status バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 95% を上回るプロセッサ時間 (ccmexec)

SMS プロバイダ

[SMS プロバイダ] ルール グループには、SMS 2003 の SMS プロバイダ コンポーネントに関連するエラーのルールが含まれています。

  • SMS 2003 依存サービスの実行 : Windows Management Instrumentation

SMS レポート ポイント

[SMS レポート ポイント] ルール グループには、SMS レポート クライアントに関連するエラーのルールが含まれています。

  • SMS 2003 サービスの実行 : SMS_REPORTING_POINT

  • SMS 2003 依存サービスの実行 : World Wide Web 発行サービス

  • SMS 2003 依存サービスの実行 : IIS 管理サービス

SMS センダ サーバー

[SMS センダ サーバー] ルール グループには、SMS センダ サーバーに関連するエラーのルールが含まれています。

  • SMS 2003 サービスの実行 : SMS_EXECUTIVE

SMS サーバー ロケータ ポイント

[SMS サーバー ロケータ ポイント] ルール グループには、SMS サーバー ロケータ ポイントに関連するエラーのルールが含まれています。

  • SMS 2003 依存サービスの実行 : World Wide Web 発行サービス

  • SMS 2003 依存サービスの実行 : IIS 管理サービス

  • SMS 2003 サービスの実行 : SMS_SERVER_LOCATOR_POINT

SMS サーバー - 共通

[SMS サーバー - 共通] ルール グループには、すべての SMS サーバーに関連するエラーのルールが含まれています。

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 98% を上回るページング ファイル使用率

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 95% を上回るプロセッサ時間 (_Total)

SMS Executive に基づく SMS サーバー

[SMS Executive に基づく SMS サーバー] ルール グループには、SMS Executive サービスを実行するサイト サーバーで生成されたエラーのルールが含まれています。

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 95% を上回るプロセッサ時間 (smsexec)

SMS サイト データベース サーバー

[SMS サイト データベース サーバー] ルール グループには、SMS サイト データベース サーバーに関連するエラーのルールが含まれています。

  • SMS 2003 サービスの実行 : SMS_SQL_MONITOR

  • SMS 2003 依存サービスの実行 : MSSQLSERVER

  • SMS 2003 パフォーマンスしきい値 : 2 時間で 500 を超える SMS SQL 接続

SMS サイト サーバー - 共通

[SMS サイト サーバー - 共通] ルール グループには、すべての SMS サイト サーバーに関連するエラーのルールが含まれています。

  • SMS 2003 サービスの実行 : SMS_SITE_COMPONENT_MANAGER

  • SMS 2003 サービスの実行 : SMS_EXECUTIVE

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるサイト サーバー スケジューラ ジョブ バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるサイト サーバー スケジューラ送信要求バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるサイト サーバー SWM バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるサイト サーバー SINV バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるサイト サーバー HINV バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるサイト サーバー DDR バックログ

SMS サイト データベース サーバー - プライマリ

[SMS サイト サーバー - プライマリ] ルール グループには、すべての SMS プライマリ サイト サーバーに関連するエラーのルールが含まれています。

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるサイト サーバー SINV バックログ

  • SMS 2003 パフォーマンスしきい値 : 3 時間で 10,000 を超えるサイト サーバー HINV バックログ

関連項目

概念

Microsoft System Management Server 2003 管理パックのその他の参考資料
SMS 2003 のコンピュータ グループ
SMS 2003 のプロバイダ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー


SMS 2003 のプロバイダ

SMS 2003 管理パックが使用するデータ プロバイダの種類は次のとおりです。

  • アプリケーション ログ

  • 時間指定イベント

  • Windows NT パフォーマンス カウンタ

関連項目

概念

Microsoft System Management Server 2003 管理パックのその他の参考資料
SMS 2003 のコンピュータ グループ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー


SMS 2003 のスクリプト

SMS 2003 管理パックには、エージェント上で自動的に実行される Operations Manager 2007 スクリプト と、管理者が実行する必要のあるスクリプトが含まれます。このセクションでは、これらのスクリプトに関する詳細について説明します。

次のスクリプトは、Operations Manager 2007 エージェントにより自動的に実行されます。

  • SMS 2003 Monitor SMS Status Messages

  • SMS 2003 Monitor Site System Summarizer

  • SMS 2003 Service Discovery – Client

  • SMS 2003 Service Discovery – Server

  • SMS 2003 Site Backup Event Suppression

  • SMS 2003 Monitor Management Point Health

  • SMS 2003: Monitor Management Point Availability

  • SMS 2003 Site Hierarchy Discovery

  • SMS 2003 Monitor SMS Inbox

  • SMS 2003 Monitor SMS Executive Crash Dumps

SMS 2003 Monitor SMS Status Messages

SMS で発生する問題の多くは、SMS ステータス システム内部で検出され、レポートされます。ステータス メッセージは、SMS 管理者が選択した条件に含まれる SMS コンポーネントによって生成されます。

ステータス メッセージは、SMS サイトのデータベースに送信され、上位サイトを経由して、親サイトのデータベースまで送信されます。SMS ステータス システムをサイトごとに監視できます。これは、特定のサイトにあるデータベースの SMS ステータス メッセージ テーブルをクエリするだけで行えます。

SMS 管理者にとって最も重大なイベントを示す一連のステータス メッセージは、あらかじめ監視対象として設定されています。それらのメッセージのいずれかがデータベースで見つかると、アラートが生成されます。

このスクリプトは、次の処理を実行します。

  • スクリプトがエージェントレスな管理モードで実行されているかどうかを確認します。エージェントレスな管理モードで実行されている場合、スクリプトはこれ以上の処理を行わずに終了します。

  • グローバル変数を初期化します。

  • SMS 2003 Monitor SMS Status Messages.VarSet ファイルが監視する SMS サイト データベースごとに、最後に処理されたステータス メッセージの RecordID を開き、読み込みます。

  • ローカル コンピュータ上の各 SMS サイト データベースにあるステータス メッセージを処理します。

  • 監視する SMS サイト データベースごとに、最後に処理されたステータス メッセージの RecordID を SMS 2003 Monitor SMS Status Messages.VarSet ファイルに書き込み、そのファイルを閉じます。

SMS 2003 Monitor SMS Status Messages スクリプトはイベントを生成し、そのイベント ID をレポート対象の SMS ステータス メッセージ ID に設定します。表 S.1 に、生成されるイベントの形式を示します。

表 S.1 SMS 2003 Monitor SMS Status Messages スクリプトによって生成されるイベントの形式

パラメータ | 説明
EventType | SMS メッセージの重大度に応じて、Success、Error、Warning、または Information を表示
EventNumber | SMS ステータス メッセージ ID
Category | SMS サイト コード
LoggingDomain | コンピュータのリソース ドメイン
LoggingComputer | コンピュータの NetBIOS 名
Parameter1 | コンピュータの NetBIOS 名
Parameter2 | SMS モジュール名 (SMS サーバーなど)
Parameter3 | SMS コンポーネント名
Parameter4 | SMS メッセージ ID
Parameter5 | Win32 エラー コード
Parameter6 | 親または最上位のサイト コード
Parameter7 | SMS ステータス メッセージ テーブル内のステータス メッセージの RecordID
Description | "サイト <Site Code> データベースで、コンポーネント <Component Name> のマシン <NetBIOS Name> に関し、監視対象の新しい SMS ステータス メッセージが見つかりました。メッセージ ID は <Message ID> です。"

SMS 2003 Monitor SMS Status Messages スクリプトは、ステータス メッセージ ID 番号 1102 で、スクリプト エラーもレポートします。

EventType= Warning

EventNumber= 1102

Description = 処理ルール <ScriptProcessingRuleName> で実行されている SMS 2003 Monitor SMS Status Messages スクリプトで、ランタイム エラーが発生しました。エラー メッセージには、"<ErrorDescription> に失敗しました" というテキストが含まれます。

SMS 2003 ステータス メッセージ 監視イベント ルールは、すべて "SMS 2003 ステータス :" という語で始まり、[SMS サイト データベース サーバー] ルール グループに含まれています。

  • SMS 2003 ステータス : メッセージの監視

SMS 2003 ステータス : メッセージの監視は、[SMS 2003 スケジュール間隔 : 30 分に 1 回、同期 : 00:02] 時間指定イベント プロバイダを使用してスクリプトを起動します。概要は、ルールの [Knowledge] プロパティ ページに表示されます。

  • SMS 2003 ステータス : スクリプト エラー

SMS 2003 ステータス : スクリプト エラーは、発生する可能性のあるスクリプト エラー イベントを監視し、それらのスクリプトに関するアラートを生成します。スクリプト エラー イベントは 1 つだけで、その番号は 1102 です。このイベントは、すべてのスクリプト エラーをレポートします。このアラートの解決方法は、ルールの [Knowledge] プロパティ ページに表示されます。

  • SMS 2003 ステータス : <status message name>

SMS 2003 ステータス : <status message name> は、特定のステータス メッセージ イベントを監視し、それらのイベントに関するアラートを生成します。このアラートの解決方法は、ルールの [Knowledge] プロパティ ページに表示されます。

各アラートには、次の形式で記述されるイベントの説明が含まれます。ここで、$Description$ はイベントの説明です。

$Logging Computer$ - "ルール名".$Description$

最後に処理されたステータス メッセージの RecordID をサイトのデータベースごとに維持するには、SMS 2003 Monitor SMS Status Messages VarSet ファイルが使用されます。VarSet ファイルは、Windows\Temp ディレクトリにあります。このファイルは、次の形式で記述されるタブ区切りファイルです。

Copy Code
LastRecordID_DBNameRecordID#

たとえば、LastRecordID_SMS_FLA、RecordID 477860 とある場合、SMS_FLA というサイト データベースによって最後に処理された RecordID は 477860 であることを示します。

以前のバージョンから管理パックをアップグレードすると、SMS 2003 Monitor SMS Status Messages VarSet ファイルに次の内容が追加されます。

Copy Code
LastRecordID476743
LastRecordID_SMS_FLA477860

1 行目にはデータベース名が含まれていません。これは、複数データベースの監視をサポートしていない旧バージョンのステータス メッセージ監視を示します。2 行目には SMS_FLA というデータベース名が含まれています。これは、現バージョンのステータス メッセージ監視では、複数のデータベースの監視がサポートされていることを示します。

複数のサイト データベースを使用する場合、最初のデータ行を使用するための処理は何も行われません。それは、最初のデータ行がどのデータベースに該当するか特定することは不可能なためです。ただし、最初のデータ行は、新しい変更を評価し、アップグレード後にステータス メッセージ監視を正しい RecordID で開始する上で重要なので、VarSet ファイルから削除されることはありません。

SMS 2003 Monitor Site System Summarizer

サイト システム サマライザ

サイト システムのステータス サマライザは、定義済みの 全 SMS サイト システムのステータスを維持する SMS Executive サービスのコンポーネント スレッドです。既定で、サイト システムのステータス サマライザは毎正時に現在のステータスをポーリングします。このポーリングの間隔は、SMS サイト制御ファイルで定義されます。ポーリングの間隔は、変更しないようお勧めします。ステータスは、SMS サイト データベースのテーブルで維持されます。

サイト システム DownSince ステータス

サイト システムのステータス サマライザは、いずれかのポーリング間隔中にサイト システムと接続できないと、そのサイト システムがダウンしたと判断します。この現象は、次のいずれかの原因で発生する可能性があります。

  • サイト システムの電源が入っていない。または、サイト システムがネットワークに接続していないか、適切に機能していない。

  • 接続数が足りないため、SMS サイト システムのステータス サマライザが接続を確立できない。

  • SMS サイト システムのステータス サマライザに、サイト システムに接続するために必要なアクセス権が付与されていない。

  • ネットワークに問題があるため、SMS サイト システムのステータス サマライザがサイト システムに接続できない。

  • サイト システムが、完全にサービスから除外されている。

サイト システムのステータス サマライザベースの可用性

サイト システムのステータス サマライザのステータスは、SMS 2003 Server Availability スクリプトおよび SMS 2003 サーバーの可用性レポートで、可用性レポートを行うために使用されます。SMS サーバーの可用性の測定では、サーバーが使用可能かどうかを特定するために、DownSince レジストリ値が使用されます。

サイト システムのステータス サマライザベースの可用性に関する制限事項

このセクションでは、SMS 2003 Server Availability スクリプトおよび SMS 2003 サーバーの可用性レポートによって使用される、可用性レポートのサイト システム サマライザ ステータスの使用に関する制限事項について説明します。SMS サーバーの可用性の測定では、サーバーが使用可能かどうかを特定するために、"DownSince" ステータスが使用されます。

サイト システムのステータス サマライザベースの可用性の監視には、次の制限事項があります。

  • サイト システム サマライザ ポーリング間隔は 1 時間です。この間隔は、サイト システムのステータス サマライザが全サイト システムをポーリングするのに十分な時間です。パフォーマンス上の理由により、この間隔は変更できません。サマライザのタイムアウト間隔は、サイト制御ファイルの Wakeup Interval プロパティではなく、Startup Schedule プロパティで制御されます。つまり、Wakeup Interval プロパティを既定値の 60 から別の値に変更しても効果はありません。また、Startup Schedule を変更しても、適用されません。既定で Startup Schedule は毎 15 分に設定されていますが、サイト システムのステータス サマライザは、設定されているこの値とは関係なく、毎正時にサイト システムをポーリングします。

  • この可用性の判断方法では、2 時間内に、"SMS 2003 サイト システム サマライザ : サイト システムがダウンしている可能性があります" イベントが連続して 2 回発生した場合にのみ、サイトがダウンしたと判断されます。この条件は、一時的なネットワーク機能停止もサイト可用性の判断材料とするように定められています。つまり、サイトが短時間使用不可になった場合でも、2 時間のサービス停止が発生したと判断されます。

  • サイト システムのステータス サマライザが検出できない仕方で、SMS が使用不可になる場合が多々あります。たとえば、SQL Server サービスが停止しているときのように、SMS サービスが実行されていない場合や、SMS サイト データベースを使用できない場合、サイト システムのステータス サマライザは SMS が使用不可であると判断できません。

  • 複数の SMS サーバー 役割をホストするコンピュータの場合、可用性データに影響が及びます。ダウンタイムは、ダウンしているサイト システムに対して生成されるアラートに基づき計算されます。アラート 1 つは、2 時間のダウンタイムが発生したことを意味します。サイト システムのステータス サマライザは、コンピュータでホストされている各サイト オブジェクトおよび各サイト システム役割について、現在の "DownSince" ステータスをサイト システムのステータス サマライザ テーブルのデータベースに書き込みます。

スクリプトを監視するサイト システムのステータス サマライザは、サイト システム サマライザ テーブル内の各サイト システム役割を調べます。そして、サイト システム ダウンとマークされていると、イベントを生成します。その後、このイベントに基づき、アラートが生成されます。このとき、複数のロールがあるとアラートがいくつも生成され、長時間のダウンタイムが発生してしまいます。この結果、対象となる間隔によっては、可用率が負になる場合があります。

各 SMS サーバー役割 (SMS 配布ポイント用を除く) は、既定で 2 つの SMS サーバー役割を設定します。一方は特定のロール用、もう一方は SMS コンポーネント サーバー用です。たとえば、サーバー ロケータ ポイントとレポート ポイント両方をホストするサイト システムで、サーバーが 2 時間 (サイト システムのステータス サマライザ ポーリング 2 間隔分) 以上オフラインになるとします。この場合、サイト システムのステータス サマライザは、これら両方のロールに加えて、それぞれの SMS コンポーネント サーバー役割もダウンしているとマークします。

ただし、アラートはサーバー役割ごと、およびそれら 2 つのサーバー役割をホストしている物理的なコンポーネント サーバーごとに 1 つずつ生成されるので、ポーリング 1 間隔で計 3 つのアラートが生成されることになります。この結果、2 時間のうち 6 時間が使用不可とマークされたことになり、可用率が負の値になります。

  • 既定では、ポーリング間隔 1 時間のサイト システムのステータス サマライザが開始して 10 分後に SMS 2003 Monitor Site System Summarizer スクリプトが実行されるように、毎正時より 10 分遅延する 60 分スケジュールが設定されています。サマライザが一連の処理を終えるのに 10 分以上要する場合、時間指定イベント プロバイダの遅延時間を長めに調整する必要があります。遅延時間を長めに調整しないと、最新のサイト システム ステータス メッセージが失われることになります。

SMS 2003: Monitor Management Point Availability

SMS 2003 Monitor Management Point Availability スクリプトは、管理ポイントの可用性レポートをサポートします。可用性は、管理ポイントの正常性の状態に基づいて判断されます。その際、レジストリに含まれる次の正常性の状態値を使用します。

DWORD 値の HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState

構成可能なスケジュールおよびレポート間隔に基づき、スクリプトは異常な状態の期間を読み取り、その後 Operations Manager 2007 イベントを使用してレポートします (レジストリ値は 0 ではなく、1 です)。

これらの可用性データ イベントは、OperationsManager データベースと OperationsManagerDW データベースに書き込まれます。その後、Operations Manager 2007 レポートを実行することで、指定した期間内で管理ポイントがダウンした合計時間と、その可用率を表示できます。

MPHealthState レジストリ値は、MP コントロール マネージャによって維持されます。このレジストリ値は、6 分ごとに更新されます。

このスクリプトは、次の処理を実行します。

  • スクリプトがエージェントレスな管理モードで実行されているかどうかを確認します。エージェントレスな管理モードで実行されている場合、スクリプトはこれ以上の処理を行わずに終了します。このスクリプトは、変数の維持にローカルの VarSet ファイルを使用するので、Operations Manager 2007 エージェントをインストールする必要があります。

  • グローバル変数を初期化します。

  • 入力パラメータ ScheduledInterval と ReportingInterval を分単位で取得します。

  • 入力パラメータが、空、0、または負でないことを確認します。パラメータがこれらのいずれかである場合、スクリプト エラー イベントが生成され、無効な値が指定されていることが示されます。スクリプトは、ReportingInterval 値が ScheduledInterval 値以上であることを確認します。ReportingInterval 値が ScheduledInterval 未満である場合、スクリプトは ReportingInterval 値が ScheduledInterval 以上でなければならないことを示すエラー イベントを生成します。どちらの値も Lng タイプを実装し、最大値 2147483647 (2G -1) を持ちます。

  • SMS 2003 Monitor Management Point Availability.VarSet ファイルを開き、その内容をローカル コレクションにコピーします。ファイルが存在しない場合、スクリプト エラー イベントは生成されません。ファイルが存在するが、そのファイルを開けない場合、スクリプト エラー イベントが生成されます。

  • 管理ポイントの可用性を確認します。

    • 現在の SMS バージョンが 2.50.3067.0000 より古い場合、MPHealthState レジストリ値は存在しません。したがって、スクリプトはエラーを生成せずに終了します。エージェント応答ログ ファイルの AgentResponses-Configuration Group Name.log には、"Monitoring Management Point health is not supported on this SMS build." というメッセージが追加されます。ログは、HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager キーにある EnableActiveDebugging DWORD 値を 1 に設定することで有効にできます。

    • レジストリ DWORD 値の HKEY_LOCAL_MACHINE\Microsoft\SMS\MP\MPHealthState から、現在の管理ポイントの正常性状態を取得します。値を取得できない場合、MP コントロール マネージャによって値が生成されていません。したがって、スクリプトはエラーを生成せずに終了します。

    • VarSet コレクションから、開始日時を取得します。スクリプトを初めて実行しており、新しいレポート期間を開始する場合、エントリはありません。スクリプトはエラーなしで終了しますが、その前に VarSet コレクションで期間と開始日時を初期化します。これにより、期間が 0 に、開始日時が現在の日時に設定されます。

    • 現在のレポート間隔について、MPHealthState レジストリ値が 1 の場合、スクリプトは指定されたスケジュール間隔で、VarSet コレクション内の使用不可の期間を 1 つ増やします。

    • レポート間隔内で管理ポイントが使用不可になった場合、そのレポート間隔の終了後に可用性データ イベントを作成し、レポートを行います。次のレポート期間に備えて、スクリプトは期間を 0 にリセットし、VarSet コレクションで維持されている開始日時を現在のローカル時刻にリセットします。

    • 管理ポイントの可用性を確認している間にエラーが発生すると、スクリプト エラーが生成されます。

Event Number = 1102

Event Type = Warning

Message = "処理ルール <ProcessingRuleName> で実行されている‘SMS 2003 Monitor Management Availability' スクリプトで、ランタイム エラーが発生しました。"CrLf "管理ポイント可用性の確認に失敗しました。" <ErrorString>

  • VarSet コレクションの内容をローカルの SMS 2003 Monitor Management Point Availability.VarSet ファイルに書き込み、そのファイルを閉じます。ファイルが存在しない場合は、そのファイルを作成します。VarSet 変数が設定されていない場合、その変数のエントリはファイルに含まれません。ファイル書き込みのエラーが発生すると、スクリプトによってスクリプト エラーが生成されます。

SMS 2003: Monitor SMS Inbox

SMS は、受信トレイのファイルを読み取ったり、ファイルに書き込んだりすることで、サーバー側の重要な処理を担います。SMS の受信トレイが異常にも一杯になる場合、SMS の処理がファイルの増加に追い付いていないことを示します。これにはさまざまな理由が考えられます。たとえば、停止したプロセス、ディスク領域の不足、ソフトウェア配布の異常な処理レベルなどがあります。これらの問題が生じることはまれですが、多数のサイトを抱える顧客にとっては深刻な事態です。

SMS 受信トレイ用のいくつかのパフォーマンス カウンタは、サービス コンポーネントによってキューに入れられたアイテム数を計測し、ディスクで処理を待機している実際のアイテム数は計測しません。SMS サービス コンポーネントは、現在のキューを処理した後、パフォーマンス カウンタを更新します。この結果、パフォーマンス カウンタの更新頻度は非常に遅くなり、重大なバックログをタイムリーに検出できなくなる可能性があります。新しい SMS 2003: Monitor SMS Inbox スクリプトは、重要な SMS サーバー 受信トレイに含まれるファイルを数えることで、受信トレイを直接監視します。また、ある受信トレイに含まれるファイル数が、ユーザー設定のしきい値を超えた場合に、Operations Manager 2007 によって管理者にアラートを通知します。

ルールはすべて [SMS サイト サーバー - 共通] 処理ルール グループに含まれます。このルール グループにより、それらのルールがセントラル、プライマリ、およびセカンダリ サイトに適用されます。スクリプトに渡されるしきい値は、上書きすることで設定できます。

パフォーマンスの理由より、これらのルールは管理ポイントまたは他の SMS サイト システム役割には適用されません。

スケジュールおよびオプションの構成

受信トレイ監視によるパフォーマンスへの影響を最小限に抑えるため、該当するルールは 1 日に 1 回実行されるよう同期されます。ルールは、一度に 1 つのルールだけが実行されるように、午前 1 時から 15 分間隔で実行されます。たとえば、最初のルールは午前 1 時に最初の受信トレイに含まれるファイルを数え、次のルールは午前 1 時 15 分に 2 番目の受信トレイに含まれるファイルを数えます。このように、最後の受信トレイまで、順次受信トレイのファイルの数が数えられます。

このスケジュールは、Operations Manager 2007 でルール スクリプトの実行をスケジュールする場合と同じ手順で変更できます。この機能を有効にするのに、初期構成は行う必要はありません。次に、オプションの構成変更を示します。

  • 各受信トレイの既定のしきい値を変更する。

  • 各受信ボックス ルールのスケジュールを変更する。

これらのオプションの構成変更は、管理パックでしきい値イベント ルールを構成する際の通常の手順で変更できます。

しきい値アラートとしきい値

監視ルールが処理されるたび、ある受信トレイ ルールの値が設定済みのしきい値に達すると、アラート 1 つが生成されます。スクリプトが無効なしきい値を検出する場合や、各受信トレイのファイル数を監視する際にエラーが発生する場合は、スクリプト エラー アラートが生成されます。

パフォーマンスしきい値を編集するには

  1. [Operations Manager 2007] 管理コンソールで、[Authoring] をクリックします。

  2. [Authoring] ペインで、[Authoring]、[Management Pack Objects]、[Monitors] の順に移動します。

  3. [Monitors] ペインで、[SMS server] を選択します。

  4. [SMS Server]、[Entity Health]、[MOM 2005 Computer Role Health] の順に移動し、編集するサーバー役割を展開します。

    • DB - データベース サーバー

    • MP - 管理ポイント サーバー

    • SS - サイト サーバー

  5. 編集するパフォーマンスしきい値監視ルールをダブルクリックします。[Performance Threshold Properties] ダイアログ ボックスが開きます。

  6. [Configuration] タブを選択します。

  7. [Edit...] をクリックします。[Xml Configuration] ダイアログ ボックスが開きます。

  8. XML テキストで、変更するしきい値を編集します。

    • 重大なエラーのしきい値を変更するには、<CriticalErrorExpression> に入れ子になった <ValueExpression> を指定します。

    • 警告のしきい値を変更するには、<WarningExpression> に入れ子になった <ValueExpression> を指定します。

  9. [OK] をクリックします。[OK] をクリックします。変更したしきい値がサーバーに配布されます。

各受信トレイ監視ルールの既定のしきい値は、10,000 に設定されています。使用する環境に合わせて、SMS 2003: Monitor SMS Inbox スクリプトの FileCountThreshold パラメータのしきい値を設定してください。有効なしきい値は、1 から 2147483647 (0x7FFFFFFF) までです。無効なしきい値は、ゼロ (0) または 2147483647 を超える数です。これは、32 ビット範囲では、これらの数が負の数になってしまうためです。

受信トレイのフォルダ、および Systems Management Server でそれらのフォルダを使用する方法の詳細については、マイクロソフト ヘルプとサポートの関連トピックを参照してください。

SMS 2003 Monitor SMS Executive Crash Dumps Script

このスクリプトは、SMS 管理コンソールの [Scripts] フォルダにあり、"SMS 2003 Monitor SMS Executive Crash Dumps" という名前が付けられています。このスクリプトは、次の処理を実行します。

  • 対象となるコンピュータがエージェントレスなモードで実行されているかどうかを確認します。エージェントレスなモードで実行されている場合、スクリプトはこれ以上の処理を行わずに終了します。このスクリプトは、変数の維持にローカルの VarSet ファイルを使用するので、対象となるコンピュータすべてに Operations Manager 2007 エージェントをインストールする必要があります。

  • ローカルの SMS 2003 Monitor SMS Executive Crash Dumps.VarSet ファイルを開き、その内容をコレクションにコピーします。ファイルが存在しない場合、スクリプト エラー イベントは生成されません。ファイルが存在するが、そのファイルを開けない場合、次のメッセージを含むスクリプト エラー イベントが生成されます。

スクリプト変数のロードに失敗しました。

  • 最後の確認以降に、新しいクラッシュ ダンプが発生していないか確認します。新しいクラッシュ ダンプが発生している場合、スクリプトは新しいクラッシュ ダンプをレポートするイベントを生成します。スクリプト エラー イベントを生成するため、スクリプトは次の処理を実行します。

    • SMS 識別キーのレジストリにある、レジストリ値 "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS\Identification\ Installation Directory" から、SMS インストール ディレクトリのパスを取得します。パスを取得できない場合、スクリプトは次のメッセージを含むスクリプト エラー イベントを生成し、終了します。

Failed to read registry value.

  • 取得した SMS インストール ディレクトリに "\Logs\CrashDumps" を追加し、CrashDumps ディレクトリの完全なパスを作成します。

  • CrashDumps ディレクトリが存在するかどうかを確認します。存在しない場合、スクリプトはフォルダの存在を確認できなかったことをログに記録し、これ以上の処理を行わずに終了します。エージェント応答ログ ファイルの AgentResponses-Configuration Group Name.log には、次のメッセージが含まれます。

クラッシュ ダンプ ディレクトリ <CrashDumpsPath> の存在を確認できませんでした。.

ログは、HKEY_LOCAL_MACHINE\SOFTWARE\Mission Critical Software\OperationsManager キーにある EnableActiveDebugging DWORD 値を 1 に設定することで有効にできます。

  • VarSet コレクションから、最後にクラッシュ ダンプ フォルダが作成された日時を取得します。

  • 新しいクラッシュ ダンプが作成されているかどうかを確認し、最も新しいクラッシュ ダンプで処理します。最も新しいダンプを特定するには、保存されている、最後のクラッシュ ダンプのフォルダ作成日時が使用されます (使用可能な場合)。日時の比較は、1 秒単位で記録されるフォルダ作成日時に基づいて行われます。

  • 新しいクラッシュ ダンプが発生するか、スクリプトが初めて実行された場合、スクリプトはそのことをログに記録し、イベント 1710 を生成して、新しいクラッシュ ダンプ フォルダとパスを指定します。スクリプトは、VarSet コレクションにクラッシュ ダンプのフォルダ作成日時を保存します。クラッシュ ダンプが発生しなかった場合、そのことがログに記録されます。

  • VarSet コレクションの内容をローカルの SMS 2003 Monitor SMS Executive Crash Dumps.VarSet ファイルに書き込み、そのファイルを閉じます。ファイルが存在しない場合は、そのファイルを作成します。VarSet 変数が設定されていない場合、その変数のエントリはファイルに含まれません。ファイル書き込みのエラーが発生すると、次の内容を含むスクリプト エラー イベント メッセージが生成されます。スクリプト変数の保存に失敗しました。

SMS 2003 Monitoring SMS Executive Crash Dump Event

SMS 2003 Monitor SMS Executive Crash Dumps スクリプトは、イベント 1710 を生成し、次に示すようにクラッシュが発生したことをレポートします。

EventType = Error

EventNumber= 1710

Category = SMS Site Code

Description = サイト "XXX" のSMS Executive がクラッシュしました。詳細については、<Drive> \SMS\Logs\CrashDumps\NewFolder にあるクラッシュ ダンプ情報を参照してください。

SMS 2003 Monitoring SMS Executive Crash Dumps Script Error Event

"SMS 2003 Monitor SMS Executive Crash Dumps" スクリプトは、イベント 1102 によってランタイム スクリプト エラーをレポートします。

EventType= Warning

EventNumber= 1102

Description = 処理ルール "SMS 2003 Crash Dumps: Monitoring SMS Executive" で実行されている "SMS 2003 Monitor SMS Executive Crash Dumps" スクリプトで、ランタイム エラーが発生しました。CrLf "<Message>に失敗しました." ErrorString

SMS 2003 Server Availability スクリプト

SMS は、デスクトップ構成管理用の重要なエンタープライズ アプリケーションです。顧客は、そのサービス可用性を追跡する必要があります。管理パックには、サンプルの Microsoft SQL Server™ スクリプトがあります。このスクリプトは、SMS サイト システムのステータス サマライザのダウン ステータスに応答して生成されるアラートに基づき、SMS サイト システムの可用性を計算します。可用性は、任意の日数に基づいて計算できます。この測定基準は、確立されたサービス レベル アグリーメント (SLA) のサポートで使用できます。

SMS 2003 Server Availability スクリプトに関する制限事項

SMS 2003 Server Availability スクリプトには、次の制限事項があります。

表示されるデータは、Operations Manager 2007 データベースのクリーンアップ間隔の制限を受けます。既定で、このスクリプトは過去 7 日間、および過去 30 日間のデータを返します。ただし、OperationsManager データベースは 4 日ごとにクリーンアップされます。したがって、7 日間隔および 30 日間隔でスクリプトを実行しても、返される結果は同じになります。さらに長期間のレポートを行うには、データベースのクリーンアップ間隔を長くするか、SMS 2003 サーバーの可用性レポートを OperationsManagerDW データベースに対して実行する必要があります。OperationsManagerDW データベースは、オペレーショナル データを長期間保存します。さらに短期間のレポートを行う場合は、スクリプトの 7 日間隔および 30 日間隔を変更する必要があります。

スクリプトのアルゴリズム

1 時間に 1 回ずつ、サイト システム サマライザは各サイト システムへの接続を試みます。サイト システムに接続できない場合、そのコンピュータはダウンしたものとしてサイト システムのステータス サマライザ テーブルに表示されます。この条件についての不正確なレポート数を減らすため、管理パックはイベントを統合し、2 時間に 2 つのイベントが発生した場合にのみアラートを生成します。ストアド プロシージャを実行すると、スクリプトは指定された日数間に発生した "サイト システムが停止した可能性があります" アラートの数を計算し、使用可能時間の合計からダウン時間を引いて、その期間の可用率を返します。指定された日数間、コンピュータで "サイト システムが停止した可能性があります" アラートが発生しなかった場合、計算される可用率は 100% になります。

毎日の傾向を確認する必要がある場合を除き、7 日間に 1 回より高い頻度でスクリプトを実行する必要はありません。

既定で、このスクリプトは過去 7 日間、および過去 30 日間のデータを返します。データの間隔を長めに設定することで、サーバー稼働時間の判定をさらに正確に行えます。間隔は、Operations Manager 2007 データベースのクリーンアップ サイクルより長い期間には設定しないでください。

次の例は、データ平均の分母となる日数を長めに設定することで、サーバーの可用率がどのように上昇するかを示しています。

  • 2 時間以内に 1 台のコンピュータについて 2 つのイベントが生成された場合、1 つのアラートが生成されます。過去 7 日間で 1 つのアラートが生成された場合、計算は次のようになります。

    • 7 日間の合計時間 = 7 × 24 = 168

    • ダウン時間の合計 = 1 × 2 = 2

    • 稼働時間の合計 = (168 - 2) = 166

    • 可用率 = (166/168) × 100 = 98.809%

  • 過去 30 日間で 1 つのアラートが生成された場合、計算は次のようになります。

    • 30 日間の合計時間 = 30 × 24 = 720

    • ダウン時間の合計 = 1 × 2 = 2

    • 稼働時間の合計 = (720 - 2) = 718

    • 可用率 = (718/720) × 100 = 99.72%

  • 過去 84 日間で 1 つのアラートが生成された場合、計算は次のようになります。

    • 84 日間の合計時間 = 84 × 24 = 2016

    • ダウン時間の合計 = 1 × 2 = 2

    • 稼働時間の合計 = (2016 - 2) = 2014

    • 可用率 = (2014/2016) × 100 = 99.9%

次の例は、同じ期間により多くのアラートがログに記録されることで、サーバーの可用率がどのように変化するかを示しています。

  • 過去 30 日間で 2 つのアラートが生成された場合、計算は次のようになります。

    • 30 日間の合計時間 = 30 × 24 = 720

    • ダウン時間の合計 = 2 × 2 = 4

    • 稼働時間の合計 = (720 - 4) = 716

    • 可用率 = (716/720) × 100 = 99.44%

  • 過去 30 日間で 3 つのアラートが生成された場合、計算は次のようになります。

    • 30 日間の合計時間 = 30 × 24 = 720

    • ダウン時間の合計 = 3 × 2 = 6

    • 稼働時間の合計 = (720 - 6) = 714

    • 可用率 = (714/720) × 100 = 99.16%

サイト システムのステータス サマライザのポーリング間隔は 1 時間に固定されており、SMS 管理コンソールを使用して変更することはできません。この間隔を変更しても、このスクリプトの正確さは向上しません。イベントの統合間隔は変更できますが、変更しても結果の正確さは向上しないため、お勧めしません。実際には、統合間隔を短くすると信頼性が低下します。これは、2 時間の統合間隔では、一時的なネットワーク機能停止による間違った結果が減るためです。

関連項目

概念

Microsoft System Management Server 2003 管理パックのその他の参考資料
SMS 2003 のコンピュータ グループ
SMS 2003 のプロバイダ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー


Microsoft SMS 2003 のビュー

SMS 2003 管理パックは、次の共通のビューを提供します。

  • アラート

  • イベント

  • SMS 2003 Site Hierarchy Diagram

  • 状態の表示

  • Task Status View

  • 全般

  • Performance

SMS 2003 用にカスタマイズされた次のビューも提供されます。

SMS 2003 Site Hierarchy Diagram

  • SMS 2003 階層

全般

  • 過去 72 時間の SMS セントラル サイト サーバーからのアラート

  • 過去 72 時間の新規アラート

パフォーマンスの表示

ビュー単位で特定のコンピュータに関するデータを表示するようにビューを構成できます。これを行うには、カスタマイズするビューを [My Workspace] にコピーし、ビューの名前を変更してから、要件に応じてビューのカスタマイズを開始することをお勧めします。対象のコンピュータごとに個別にカウンタを選択すると、グラフの複雑さを軽減できます。

バックログ\管理ポイント サーバー

  • 過去 48 時間の DDR バックログ

  • 過去 48 時間の FileCollection バックログ

  • 過去 48 時間の HINV バックログ

  • 過去 48 時間のリレー バックログ

  • 過去 48 時間の SINV バックログ

  • 過去 48 時間のステータス バックログ

バックログ\サイト サーバー

  • 過去 48 時間の DDR バックログ

  • 過去 48 時間の HINV バックログ

  • 過去 48 時間のスケジューラ ジョブ バックログ

  • 過去 48 時間のスケジューラ送信要求バックログ

  • 過去 48 時間の SINV バックログ

  • 過去 48 時間の SWM バックログ

全般\管理ポイント サーバー

  • 過去 48 時間の LogicalDisk

  • 過去 48 時間のメモリ

  • 過去 48 時間のプロセッサ

全般\サイト サーバー

  • 過去 48 時間の LogicalDisk

  • 過去 48 時間のメモリ

  • 過去 48 時間のプロセッサ

メモ
[過去 48 時間の LogicalDisk] ビューのパフォーマンス プロバイダは、Microsoft Windows Server Base Operating System 管理パックと共にインストールされます。

処理率

  • *過去 24 時間の SMS 2003 管理ポイント サーバー上のすべてのメッセージ処理率

  • *過去 24 時間の SMS 2003 管理ポイント サーバー上のすべてのレポート処理率

  • *過去 24 時間の SMS 2003 サイト サーバー上のすべてのレポート処理率

処理率\管理ポイント サーバー

  • 過去 24 時間の DDRs/sec

  • 過去 24 時間の DM Database Connection Attempts/sec

  • 過去 24 時間の DM DDRs/sec

  • 過去 24 時間の DM Discovery Translation Requests/sec

  • 過去 24 時間の DM DP Locations/sec

  • 過去 24 時間の DM Hardware Inventory Translation Requests/sec

  • 過去 24 時間の DM HINVs/sec

  • 過去 24 時間の DM ISAPI Requests/sec

  • 過去 24 時間の DM Machine Setting Requests/sec

  • 過去 24 時間の DM Package Version Requests/sec

  • 過去 24 時間の DM SINVs/sec

  • 過去 24 時間の DM Software Policy Body Requests/sec

  • 過去 24 時間の DM Software Policy ID Requests/sec

  • 過去 24 時間の DM Status/sec

  • 過去 24 時間の DM Total Setting Requests/sec

  • 過去 24 時間の DP Locations/sec

  • 過去 24 時間の GetAuth Requests/sec

  • 過去 24 時間の GetPolicy Requests/sec

  • 過去 24 時間の HINVs/sec

  • 過去 24 時間の ISAPI Requests/sec

  • 過去 24 時間の MP Locations/sec

  • 過去 24 時間の PA Requests/sec

  • 過去 24 時間の Relay Reports/sec

  • 過去 24 時間の SINVs/sec

  • 過去 24 時間の SPs Executed/sec

  • 過去 24 時間の Status/sec

  • 過去 24 時間の DDR の総数

  • 過去 24 時間の DM DDR の総数

  • 過去 24 時間の DM HINV の総数

  • 過去 24 時間にディスパッチされた DM ISAPI 要求の総数

  • 過去 24 時間に受信した DM ISAPI 要求の総数

  • 過去 24 時間の DM SINV の総数

  • 過去 24 時間の DM ステータスの総数

  • 過去 24 時間の HINV の総数

  • 過去 24 時間のリレー レポートの総数

  • 過去 24 時間の SINV の総数

  • 過去 24 時間のステータスの総数

処理率\サイト データベース サーバー

  • 過去 24 時間の SQL Server ユーザー接続

処理率\サイト サーバー

  • 過去 24 時間の DDRs/minute

  • 過去 24 時間の HINVs/minute

  • 過去 24 時間の SINVs/minute

  • 過去 24 時間の Status/minute

  • 過去 24 時間の SINVs/minute

  • 過去 24 時間の DDR の総数

  • 過去 24 時間の HINV の総数

  • 過去 24 時間の SINV の総数

  • 過去 24 時間のステータスの総数

  • 過去 24 時間の SWM の総数

関連項目

概念

Microsoft System Management Server 2003 管理パックのその他の参考資料
SMS 2003 のコンピュータ グループ
SMS 2003 のプロバイダ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー


SMS 2003 のダイアグラム

SMS 2003 管理パックは、SMS 階層を表すトポロジ図を提供します。この図にはサイト サーバーとサイト システムが表示され、互いの関係が状況に依存した情報と共に示されます。トポロジ図には、階層やサイトなどの論理データ、およびサイト サーバーやサイト システムなどの物理データが含まれます。SMS 2003 階層の規模が大きい場合は、[グループ] フィルタを使用して、表示する範囲を任意の SMS 2003 コンピュータ グループに限定することができます。

Operations Manager 2007 の SMS 2003 管理パックでトポロジ図を表示するには、次の要件を満たす必要があります。

  • トポロジ図に含める SMS サーバーに SMS 2003 SP3 がインストールされている。

  • トポロジ図が有効になっている。

  • サイトの役割はすべて、完全修飾ドメイン名 (FQDN) で構成されている。構成は、SMS 2003 管理コンソールを使用して行います。

トポロジ検索を実行して SMS 2003 階層のダイアグラムを作成するには、SMS プロバイダが管理されたコンピュータであり、それらのコンピュータにエージェントがインストールされていなければなりません。加えて、他のコンピュータに対するエージェント プロキシが有効になっている必要があります。また、サイト サーバーとサイト システム間の接続を表示するには、サイト システムが SMS 検出処理によって検出されており、[すべてのシステム] コレクションのメンバである必要があります。

検出は、プライマリ サイトからサイト単位で実行され、セカンダリ サイトは親プライマリ サイトの検出時に検出されます。検出されたデータは、ツール ヒントやサーバーのコメントとして表示されます。ダイアグラムは、Microsoft Visio® ファイル形式でエクスポートすることもできます。

SMS サーバー トポロジ イメージのコメント

サーバーの種類のアイコン

  • データベース サーバーの種類 : サイト データベース

  • サイト システムの種類 : 管理ポイント

  • サーバーの種類 : セントラル サイト、プライマリ サイト、セカンダリ サイト、サイト システム

線の色とスタイル

線の色とスタイルは、2 台のコンピュータ間の関係の種類を表します。

  • サイト サーバーとサイト サーバーをつなぐ線は、黒の実線です。

  • サイト サーバーとサイト システムをつなぐ線は、青の点線です。

関連項目

概念

Microsoft System Management Server 2003 管理パックのその他の参考資料
SMS 2003 のコンピュータ グループ
SMS 2003 のプロバイダ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー


SMS 2003 のレポート

このセクションでは、SMS 2003 管理パックで使用できるレポートについて説明します。レポートは、オプション コンポーネントであり、インストールは別個に行う必要があります。レポート サーバーの展開に関する詳細については、Operations Manager 2007 の製品 Web ページ (http://go.microsoft.com/fwlink/?LinkID=83259) (英語の可能性あり) を参照してください。

SMS レポート

Systems Management Server 2003 管理パックには、3 種類のレポートがあります。

  • パフォーマンス

  • 構成

  • 可用性

レポートは、オブジェクト ピッカーを使用して選択されるグループやオブジェクトに対して実行されます。レポートはすべて、Operations Manager 2007 のレポート機能を利用してリンクされています。エクスポート可能なレポート形式は計 7 種類あり、適切なものを選択できます。

可用性レポート

SMS 2003 管理パックには、3 種類の可用性レポートがあります。これらのレポートは、SMS サーバー グループ (Microsoft.SMS.2003.ServersGroup) を選択することにより、Microsoft.SMS.2003.ServersGroup オブジェクト ピッカー ターゲット グループに対して実行できます。

サーバーの可用性レポート

サーバーの可用性レポートは、特定のサーバー上に存在する、すべてのエンティティの全体的な正常性の状態に基づいて作成されます。このレポートでは、監視されている他の役割の正常性に加えて、SMS モニタの役割の正常性も報告されます。

サイト サーバーの可用性

サーバーの可用性レポートは、サイト サーバーの正常性の状態に基づいて作成されます。このレポートでは、正常性モニタの情報が使用されます。

管理ポイントの可用性レポート

管理ポイントの可用性レポートは、管理ポイントの正常性の状態に基づいて作成されます。このレポートでは、正常性モニタの情報が使用されます。

構成レポート

SMS 2003 管理パックで使用できる構成レポートは、SMS 2003 サーバー カスタム構成レポートの 1 つだけです。このレポートは、SMS サーバーまたは SMS サーバーのグループのプロパティを含む、基本的なカスタム構成レポートです。

このレポートでは、次の SMS プロパティが表示されます。

  • バージョン (SMS 製品バージョン)

  • サイト システムの種類 (サイト システムの種類、サーバーの種類、データベース サーバーの種類)

  • コンポーネント (サイト サーバー、サーバー ロケータ ポイント、配布ポイント、管理ポイント、レポート ポイント、データベース サーバー、プロバイダ、センダ、クライアント アクセス ポイント)

  • サイト コード (SMS サイト コード)

  • サーバーの種類 (セントラル、プライマリ、セカンダリ サイト サーバー)

  • 名前 (NetBIOS 名)

  • データベース サーバーの種類 (サイト データベース サーバー)

このレポートは、Microsoft.SMS.2003.ServersGroup オブジェクト ピッカー ターゲット グループに対して実行できます。

パフォーマンス

パフォーマンス レポートは、監視対象のサイトの役割に基づいてグループ化され、さらにカウンタの種類に応じて分類されます。カウンタには、単位あたりのパフォーマンスを示すカウンタ (毎秒または毎分など)、および基本パフォーマンスを示すカウンタ (総数) があります。このグループ分けによって、1 つのレポートに関係するすべてのカウンタがほぼ同じ測定尺度に基づくことになります。

レポートは、必要とされる分析の種類に基づいて開発されてきました。必要とされる分析の種類に応じて、2 種類のレポート セットが用意されています。1 つは、特定の SMS サーバー役割 (管理ポイントやサイト サーバーなど) のパフォーマンス カウンタすべてを示すレポート セットです。もう一方は、すべてのサイト役割における特定の処理オブジェクト (ハードウェア インベントリなど) のカウンタをすべて示します。

SMS 2003 サーバー パフォーマンス グループのレポート

次のレポートを実行するには、オブジェクト ピッカー ターゲット グループで Microsoft.SMS.2003.ServerPerformanceGroup を選択します。

SMS 2003 データ探索レコード (DDR) 基本パフォーマンス

このレポートでは、該当するすべての SMS サーバー役割のデータ探索レコード (DDR) バックログおよび処理総数が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー DDR バックログ | Total DDRs Enqueued
SMS 2003 パフォーマンス測定 : サイト サーバー DDR 処理総数 | Total DDRs Processed
SMS 2003 パフォーマンス測定 : MP DDR バックログ | Messages Qeued
SMS 2003 パフォーマンス測定 : MP DDR Mgr (Total Reports) | Total Reports
SMS 2003 パフォーマンス測定 : DMP DDR 処理総数 | Total Discovery Reports Generated

SMS 2003 データ探索レコード (DDR) パフォーマンス比率

このレポートでは、該当するすべての SMS サーバー役割のデータ探索レコード (DDR) 処理率が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー DDR 処理率 | DDRs Processed/minute
SMS 2003 パフォーマンス測定 : MP DDR Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : DMP DDR 処理率 | Discovery Reports Generated/sec

SMS 2003 ハードウェア インベントリ (HINV) 基本パフォーマンス

このレポートでは、該当するすべての SMS サーバー役割のハードウェア インベントリ (HINV) バックログおよび処理総数が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー HINV バックログ | Total MIFs Enqueued
SMS 2003 パフォーマンス測定 : サイト サーバー HINV 処理総数 | Total MIFs Processed
SMS 2003 パフォーマンス測定 : MP HINV バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP HINV Mgr (Total Reports) | Total Reports
SMS 2003 パフォーマンス測定 : DMP HINV 処理総数 | Total Hardware Inventory Reports Generated

SMS 2003 ハードウェア インベントリ (HINV) パフォーマンス比率

このレポートでは、該当するすべての SMS サーバー役割のハードウェア インベントリ (HINV) 処理率が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー HINV 処理率 | MIFs Processed/minute
SMS 2003 パフォーマンス測定 : MP HINV Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : MP HINV Retry Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : DMP HINV 処理率 | Hardware Inventory Reports Generated /sec

SMS 2003 ソフトウェア インベントリ (SINV) 基本パフォーマンス

このレポートでは、該当するすべての SMS サーバー役割のソフトウェア インベントリ (SINV) バックログおよび処理総数が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー SINV バックログ | Total SINVs Enqueued
SMS 2003 パフォーマンス測定 : サイト サーバー SINV 処理総数 | Total SINVSs Processed
SMS 2003 パフォーマンス測定 : MP FileCollection バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP SINV バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP Sinv Mgr (Total Reports) | Total Reports
SMS 2003 パフォーマンス測定 : DMP SINV 処理総数 | Total Software Inventory Reports Generated

SMS 2003 ソフトウェア インベントリ (SINV) パフォーマンス比率

このレポートでは、該当するすべての SMS サーバー役割のソフトウェア インベントリ (SINV) 処理率が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー SINV 処理率 | SINVs Processed/minute
SMS 2003 パフォーマンス測定 : MP Sinv Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : MP Sinv ColFile Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : DMP SINV 処理率 | Software Inventory Reports Generated /sec

SMS 2003 サーバー システム リソースのパフォーマンス

このレポートでは、SMS サーバー役割によるシステム リソースの使用量が表示されます。

SMS 2003 パフォーマンス測定 : メモリ - %Committed bytes in Use | Committed Bytes In Use
SMS 2003 パフォーマンス測定 : ページング ファイル - %Usage | % Usage
SMS 2003 パフォーマンス測定 : プロセッサ - % Processor time (_Total) | % Processor Time
SMS 2003 パフォーマンス測定 : プロセス - % Processor time (smsexec) | % Processor Time
SMS 2003 パフォーマンス測定 : プロセス - % Processor time (ccmexec) | % Processor Time
SMS 2003 パフォーマンス測定 : システム - System Up Time | System Up Time

SMS 2003 ソフトウェア メータリング (SWM) 基本パフォーマンス

このレポートでは、該当するすべての SMS サーバー役割のソフトウェア メータリング (SWM) バックログおよび処理総数が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー SWM バックログ | Total SWM Usage Files Enqueued
SMS 2003 パフォーマンス測定 : サイト サーバー SWM 処理総数 | Total SWM Usage Records Processed
SMS 2003 パフォーマンス測定 : MP Relay Mgr バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP Relay Mgr (Total Reports) | Total Reports

SMS 2003 ソフトウェア メータリング (SWM) パフォーマンス比率

このレポートでは、該当するすべての SMS サーバー役割のソフトウェア メータリング (SWM) 処理率が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー SWM 処理率 | SWM Usage Records Processed/minute
SMS 2003 パフォーマンス測定 : MP Relay Mgr (Total Reports/sec) | Total Reports/sec

SMS 2003 ステータス メッセージの基本パフォーマンス

このレポートでは、該当するすべての SMS サーバー役割の SMS ステータス メッセージ バックログおよび処理総数が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバーのステータス メッセージ処理総数 | Received
SMS 2003 パフォーマンス測定 : MP ステータス バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP Status Mgr (Total Events) | Total Events
SMS 2003 パフォーマンス測定 : DMP ステータス メッセージ処理総数 | Total Status Messages Raised

SMS 2003 ステータス メッセージのパフォーマンス比率

このレポートでは、該当するすべての SMS サーバー役割の SMS ステータス メッセージの処理率が表示されます。

SMS 2003 パフォーマンス測定 : サイト サーバー ステータス処理率 | Processed/sec
SMS 2003 パフォーマンス測定 : MP Status Mgr (Total Events/sec) | Total Events/sec
SMS 2003 パフォーマンス測定 : DMP ステータス処理率 | Status Messages Raised /sec

SMS 2003 サーバー役割のサポートのパフォーマンス

このレポートでは、SMS サーバー役割をサポートするサービスのパフォーマンスが表示されます。

SMS 2003 パフォーマンス測定 : Web サービス (ISAPI Extension Requests/sec) | ISAPI Extension Requests/sec
SMS 2003 パフォーマンス測定 : SMS SQL 接続 | User Connections

SMS 2003 管理ポイント サーバーのレポート

次のレポートを実行するには、オブジェクト ピッカー ターゲット グループで Microsoft Management Point Servers を選択します。

SMS 2003 デバイス管理ポイントの基本パフォーマンス

このレポートでは、SMS デバイス管理ポイントのサーバー役割の処理総数が表示されます。

SMS 2003 パフォーマンス測定 : DMP DDR 処理総数 | Total Discovery Reports Generated
SMS 2003 パフォーマンス測定 : DMP HINV 処理総数 | Total Hardware Inventory Reports Generated
SMS 2003 パフォーマンス測定 : DMP SINV 処理総数 | Total Software Inventory Reports Generated
SMS 2003 パフォーマンス測定 : DMP ステータス メッセージ処理総数 | Total Status Messages Raised
SMS 2003 パフォーマンス測定 : DMP ディスパッチされた ISAPI 要求の総数 | Total Message Dispatched
SMS 2003 パフォーマンス測定 : DMP 受信した ISAPI 要求の総数 | Total Messages Received

SMS 2003 デバイス管理ポイントのパフォーマンス比率

このレポートでは、SMS デバイス管理ポイントのサーバー役割の処理率が表示されます。

SMS 2003 パフォーマンス測定 : DMP 設定要求の処理率 | Dmp Setting Requests/sec
SMS 2003 パフォーマンス測定 : DMP マシン設定要求の処理率 | Machine Setting Requests/sec
SMS 2003 パフォーマンス測定 : DMP ソフトウェア ポリシー ID 要求の処理率 | Software Policy ID Requests/sec
SMS 2003 パフォーマンス測定 : DMP ソフトウェア ポリシー ボディ要求の処理率 | Software Policy Body Requests/sec
SMS 2003 パフォーマンス測定 : DMP パッケージ バージョン要求の処理率 | Package Version Requests/sec
SMS 2003 パフォーマンス測定 : DMP 検索変換要求の処理率 | Discovery Translation Requests/sec
SMS 2003 パフォーマンス測定 : DMP ハードウェア インベントリ変換要求の処理率 | Hardware Inventory Translation Requests/sec
SMS 2003 パフォーマンス測定 : DMP データベース接続試行回数の比率 | Database Connection Attempts/sec
SMS 2003 パフォーマンス測定 : DMP DDR 処理率 | Discovery Reports Generated/sec
SMS 2003 パフォーマンス測定 : DMP HINV 処理率 | Hardware Inventory Reports Generated /sec
SMS 2003 パフォーマンス測定 : DMP DP 場所の要求の処理率 | Location Requests Generated /sec
SMS 2003 パフォーマンス測定 : DMP ISAPI メッセージ処理率 | Messages Dispatched/sec
SMS 2003 パフォーマンス測定 : DMP SINV 処理率 | Software Inventory Reports Generated /sec
SMS 2003 パフォーマンス測定 : DMP ステータス処理率 | Status Messages Raised /sec

SMS 2003 管理ポイントの基本パフォーマンス

このレポートでは、SMS 管理ポイントのサーバー役割のバックログおよび処理総数が表示されます。

SMS 2003 パフォーマンス測定 : MP DDR バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP DDR Mgr (Total Reports) | Total Reports
SMS 2003 パフォーマンス測定 : MP HINV バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP HINV Mgr (Total Reports) | Total Reports
SMS 2003 パフォーマンス測定 : MP FileCollection バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP SINV バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP SINV Mgr (Total Reports) | Total Reports
SMS 2003 パフォーマンス測定 : MP Relay Mgr バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP Relay Mgr (Total Reports) | Total Reports
SMS 2003 パフォーマンス測定 : MP ステータス バックログ | Messages Queued
SMS 2003 パフォーマンス測定 : MP Status Mgr (Total Events) | Total Events

SMS 2003 管理ポイントのパフォーマンス比率

このレポートでは、SMS 管理ポイントのサーバー役割の処理率が表示されます。

SMS 2003 パフォーマンス測定 : MP Location Mgr (MP Requests/sec) | MP Requests/second
SMS 2003 パフォーマンス測定 : MP Location Mgr (DP Requests/sec) | DP Requests/second
SMS 2003 パフォーマンス測定 : MP Get Policy (Requests/sec) | Requests/second
SMS 2003 パフォーマンス測定 : MP Get Auth (Requests/sec) | Requests/second
SMS 2003 パフォーマンス測定 : MP Policy Mgr (PA Requests/sec) | PA Requests/second
SMS 2003 パフォーマンス測定 : MP DAL (SPs Executed/sec) | SPs Executed/second
SMS 2003 パフォーマンス測定 : MP HINV Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : MP HINV Retry Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : MP SINV Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : MP SINV ColFile Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : MP Relay Mgr (Total Reports/sec) | Total Reports/sec
SMS 2003 パフォーマンス測定 : MP Status Mgr (Total Events/sec) | Total Events/sec

関連項目

概念

Microsoft System Management Server 2003 管理パックのその他の参考資料
SMS 2003 のコンピュータ グループ
SMS 2003 のプロバイダ
SMS 2003 のダイアグラム
SMS 2003 のレポート

その他のリソース

SMS 2003 管理パックのサイトおよびコンポーネント
SMS 2003 のルール グループ
SMS 2003 のスクリプト
Microsoft SMS 2003 のビュー